<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><title>Six Villages To Hold Elections On March 20 | Great Neck Record</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="http://greatneckrecord.com/xmlrpc.php" /><meta property="og:image" content="http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif" /><link rel="icon" type="image/png" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-16x16.jpg"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-76x76.jpg"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-120x120.jpg"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-152x152.jpg"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-114x114.jpg"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-144x144.jpg"/><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//s.gravatar.com' /><link rel='dns-prefetch' href='//maps.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Feed" href="http://greatneckrecord.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Comments Feed" href="http://greatneckrecord.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Great Neck Record &raquo; iCal Feed" href="http://greatneckrecord.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Six Villages To Hold Elections On March 20 Comments Feed" href="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/greatneckrecord.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.0' type='text/css' media='all' /><link rel='stylesheet' id='js_composer_front-css'  href='http://greatneckrecord.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.1.1' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css'  href='http://greatneckrecord.com/wp-content/themes/Newspaper-child/style.css?ver=8.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://greatneckrecord.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' /> <script type='text/javascript' src='http://greatneckrecord.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <link rel='https://api.w.org/' href='http://greatneckrecord.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://greatneckrecord.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://greatneckrecord.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Chinese Community Thanks Social Center' href='http://greatneckrecord.com/chinese-community-thanks-social-center/' /><link rel='next' title='Seventh Annual Row For Autism Regatta To Take Place April 15' href='http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/' /><meta name="generator" content="WordPress 4.9.4" /><link rel="canonical" href="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" /><link rel='shortlink' href='https://wp.me/p2nBAD-9Od' /><link rel="alternate" type="application/json+oembed" href="http://greatneckrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" /><link rel="alternate" type="text/xml+oembed" href="http://greatneckrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F&#038;format=xml" /> <style type="text/css">div#map.slp_map {
width:100%;
height:480px;
}
div#slp_tagline {
width:100%;
}</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://greatneckrecord.com"><link rel="https://theeventscalendar.com/" href="http://greatneckrecord.com/wp-json/tribe/events/v1/" /><link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//jetpack.wordpress.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//s1.wp.com'/><link rel='dns-prefetch' href='//s2.wp.com'/><link rel='dns-prefetch' href='//public-api.wordpress.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://greatneckrecord.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta property="og:type" content="article" /><meta property="og:title" content="Six Villages To Hold Elections On March 20" /><meta property="og:url" content="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" /><meta property="og:description" content="Voters will head to the polls in the villages of Great Neck Estates, Great Neck Plaza, Kensington, Russell Gardens, Saddle Rock and Thomaston on Tuesday, March 20, as two mayors are up for reelecti…" /><meta property="article:published_time" content="2018-03-16T10:12:48+00:00" /><meta property="article:modified_time" content="2018-03-13T16:54:52+00:00" /><meta property="og:site_name" content="Great Neck Record" /><meta property="og:image" content="http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif" /><meta property="og:image:width" content="300" /><meta property="og:image:height" content="300" /><meta property="og:locale" content="en_US" /><meta name="twitter:site" content="@GreatNeckRecord" /><meta name="twitter:text:title" content="Six Villages To Hold Elections On March 20" /><meta name="twitter:image" content="http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif?w=640" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@GreatNeckRecord" />  <script>var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var td_ajax_url="http:\/\/greatneckrecord.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.0";
var td_get_template_directory_uri="http:\/\/greatneckrecord.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script> <style>ul.sf-menu > .td-menu-item > a {
        font-size:14px;
	font-weight:normal;
	
    }</style> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65941892-2', 'auto');
  ga('send', 'pageview');</script><script type="application/ld+json">{
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://greatneckrecord.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://greatneckrecord.com/category/news/",
                                "name": "Great Neck News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/",
                                "name": "Six Villages To Hold Elections On March 20"                                
                            }
                        }    ]
                        }</script> <style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


@media (max-width: 767px){
.td-header-sp-top-menu {
    display: block !important; 
}
}
@media (max-width: 767px)
{
	.td-header-top-menu-full {
    display:  block !important;
}
}
.top_menu_space{top: 30px !important;}

.td-banner-wrap-full.td-logo-wrap-full.td-container-wrap{margin-top: 28px;}

.td-header-top-menu-full.td-container-wrap {position: fixed;
    width: 100%;
    top: 0px;} 
.td-header-menu-wrap.td-affix{top: 28px !important;}</style><noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script type='text/javascript'>(function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();</script> <script src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>googletag.cmd.push(function() {
    googletag.defineSlot('/33457410/1x1GreatN', [1, 1], 'div-gpt-ad-1497370821859-0').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_BottomRtRail', [300, 250], 'div-gpt-ad-1497370821859-1').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_Leader', [728, 90], 'div-gpt-ad-1497370821859-2').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_728x90_pgal', [728, 90], 'div-gpt-ad-1497370821859-3').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_ATF_Cube', [300, 250], 'div-gpt-ad-1497370821859-4').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeA', [300, 250], 'div-gpt-ad-1497370821859-5').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeB', [300, 250], 'div-gpt-ad-1497370821859-6').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });</script> <script type='text/javascript'>googletag.cmd.push(function() {
    googletag.defineSlot('/33457410/1x1GreatN', [1, 1], 'div-gpt-ad-1463590303247-0').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_Leader', [728, 90], 'div-gpt-ad-1463590303247-1').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_728x90_pgal', [728, 90], 'div-gpt-ad-1463590303247-2').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_Leader', [728, 90], 'div-gpt-ad-1463590303247-3').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_ATF_Cube', [300, 250], 'div-gpt-ad-1463590303247-4').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeA', [300, 250], 'div-gpt-ad-1463590303247-5').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeB', [300, 250], 'div-gpt-ad-1463590303247-6').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65941892-2', 'auto');
  ga('send', 'pageview');</script> </head><body class="post-template-default single single-post postid-37709 single-format-standard tribe-no-js six-villages-to-hold-elections-on-march-20 global-block-template-1 wpb-js-composer js-comp-ver-5.1.1 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GreatNeckRecord/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://plus.google.com/b/117482670940543624944" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/greatneckrecord" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-368" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-368"><a href="http://greatneckrecord.com">Home</a></li><li id="menu-item-369" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-369"><a href="http://greatneckrecord.com/category/news/">Great Neck News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-21832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21832"><a href="http://greatneckrecord.com/category/fire-police/">Fire &#038; Police</a></li></ul></li><li id="menu-item-370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-370"><a href="http://greatneckrecord.com/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2299" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2299"><a href="http://greatneckrecord.com/events/">All Events</a></li></ul></li><li id="menu-item-429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-429"><a href="http://greatneckrecord.com/category/school-news/">School News</a></li><li id="menu-item-14001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14001"><a href="http://greatneckrecord.com/category/arts/">Arts</a></li><li id="menu-item-14002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14002"><a href="http://greatneckrecord.com/category/sports/">Sports</a></li><li id="menu-item-16221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16221"><a href="http://greatneckrecord.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-21836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21836"><a href="http://greatneckrecord.com/category/opinion/columns/">Columns</a></li><li id="menu-item-16222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16222"><a href="http://greatneckrecord.com/category/opinion/editorials/">Editorials</a></li><li id="menu-item-16223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16223"><a href="http://greatneckrecord.com/category/opinion/letters-to-editor/">Letters to the Editor</a></li></ul></li><li id="menu-item-13605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13605"><a href="http://greatneckrecord.com/category/great-neck-magazine/">Magazine<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2801"><a href="http://greatneckrecord.com/magazine/">Great Neck Magazine</a></li></ul></li><li id="menu-item-18150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18150"><a href="http://longislandweekly.com/category/specials/">Specials<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-18151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18151"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li><li id="menu-item-18152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18152"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li><li id="menu-item-18153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18153"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li><li id="menu-item-18154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18154"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li><li id="menu-item-18156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18156"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li><li id="menu-item-18157" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18157"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li><li id="menu-item-18159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18159"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li><li id="menu-item-18160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18160"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li><li id="menu-item-18161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18161"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li><li id="menu-item-33419" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33419"><a href="https://longislandweekly.com/category/specials/">More</a></li></ul></li><li id="menu-item-21834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-21834"><a href="http://greatneckrecord.com/#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-26339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26339"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li><li id="menu-item-21833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21833"><a href="http://greatneckrecord.com/category/obituaries/">Obituaries</a></li><li id="menu-item-14042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14042"><a href="http://greatneckrecord.com/town-bulletin-board/">Important Info</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="http://greatneckrecord.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="td-header-wrap td-header-style-1"><div class="td-header-top-menu-full td-container-wrap  top_menu_space1"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-14007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-14007"><a href="http://antonnews.com">Edition</a><ul class="sub-menu"><li id="menu-item-24894" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24894"><a href="https://longislandweekly.com/">Long Island Weekly</a></li><li id="menu-item-24877" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24877"><a href="http://farmingdale-observer.com/">Farmingdale</a></li><li id="menu-item-24878" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24878"><a href="http://floralparkdispatch.com/">Floral Park</a></li><li id="menu-item-24879" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24879"><a href="http://gardencity-life.com/">Garden City</a></li><li id="menu-item-24880" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24880"><a href="http://glencoverecordpilot.com/">Glen Cove</a></li><li id="menu-item-24882" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24882"><a href="http://hicksvillenews.com/">Hicksville</a></li><li id="menu-item-24883" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24883"><a href="http://levittown-tribune.com/">Levittown ∙ Wantagh</a></li><li id="menu-item-24884" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24884"><a href="http://manhassetpress.com/">Manhasset</a></li><li id="menu-item-24885" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24885"><a href="http://www.massapequaobserver.com/">Massapequa</a></li><li id="menu-item-24886" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24886"><a href="http://mineolaamerican.com/">Mineola</a></li><li id="menu-item-24887" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24887"><a href="http://newhydeparkillustrated.com/">New Hyde Park</a></li><li id="menu-item-24888" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24888"><a href="http://oysterbayenterprisepilot.com/">Oyster Bay</a></li><li id="menu-item-24889" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24889"><a href="http://plainviewoldbethpageherald.com/">Plainview ∙ Old Bethpage</a></li><li id="menu-item-24890" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24890"><a href="http://portwashington-news.com/">Port Washington</a></li><li id="menu-item-24891" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24891"><a href="http://roslyn-news.com/">Roslyn ∙ Greenvale</a></li><li id="menu-item-24892" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24892"><a href="http://syossetjerichotribune.com/">Syosset ∙ Jericho</a></li><li id="menu-item-24893" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24893"><a href="http://thewestburytimes.com/">Westbury ∙ Carle Place</a></li></ul></li><li id="menu-item-33122" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33122"><a href="http://greatneckrecord.com/newsstands/">Newsstands</a></li><li id="menu-item-14004" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-14004"><a href="http://greatneckrecord.com/advertise-with-anton-newspapers/">Advertise</a></li><li id="menu-item-14005" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-14005"><a href="https://antonnews.com/subscription/">Subscribe</a></li><li id="menu-item-16694" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-16694"><a href="http://greatneckrecord.com/contact-us/">Contact Us</a></li><li id="menu-item-15221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-15221"><a href="http://greatneckrecord.com/newspaper-in-education/">Newspaper In Education</a><ul class="sub-menu"><li id="menu-item-22706" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-22706"><a href="https://longislandweekly.com/category/newspaper-in-education/">Lesson Plans</a></li></ul></li></ul></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap "><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-544x180-300x99.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg" alt="Great Neck Record" title="Great Neck Record"/> <span class="td-visual-hidden">Great Neck Record</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  "><div id='div-gpt-ad-1463590303247-3' style='height:90px; width:728px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-3'); });</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap "><div class="td-header-menu-wrap td-header-gradient"><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-disable" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-280x96.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-140x48.jpg" alt="Great Neck Record" title="Great Neck Record"/> </a> <a class="td-header-logo td-sticky-disable" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-544x180-300x99.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg" alt="Great Neck Record" title="Great Neck Record"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-368"><a href="http://greatneckrecord.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-369"><a href="http://greatneckrecord.com/category/news/">Great Neck News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21832"><a href="http://greatneckrecord.com/category/fire-police/">Fire &#038; Police</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-370"><a href="http://greatneckrecord.com/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-2299"><a href="http://greatneckrecord.com/events/">All Events</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-429"><a href="http://greatneckrecord.com/category/school-news/">School News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14001"><a href="http://greatneckrecord.com/category/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14002"><a href="http://greatneckrecord.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-16221"><a href="http://greatneckrecord.com/category/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21836"><a href="http://greatneckrecord.com/category/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16222"><a href="http://greatneckrecord.com/category/opinion/editorials/">Editorials</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16223"><a href="http://greatneckrecord.com/category/opinion/letters-to-editor/">Letters to the Editor</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-13605"><a href="http://greatneckrecord.com/category/great-neck-magazine/">Magazine</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2801"><a href="http://greatneckrecord.com/magazine/">Great Neck Magazine</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-18150"><a href="http://longislandweekly.com/category/specials/">Specials</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18151"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18152"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18153"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18154"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18156"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18157"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18159"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18160"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18161"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33419"><a href="https://longislandweekly.com/category/specials/">More</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children td-menu-item td-normal-menu menu-item-21834"><a href="http://greatneckrecord.com/#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26339"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21833"><a href="http://greatneckrecord.com/category/obituaries/">Obituaries</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-14042"><a href="http://greatneckrecord.com/town-bulletin-board/">Important Info</a></li></ul></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="http://greatneckrecord.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://greatneckrecord.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Great Neck News" class="entry-crumb" href="http://greatneckrecord.com/category/news/">Great Neck News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Six Villages To Hold Elections On March 20</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-37709" class="post-37709 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news" itemscope itemtype="http://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="http://greatneckrecord.com/category/news/">Great Neck News</a></li></ul><header class="td-post-title"><h1 class="entry-title">Six Villages To Hold Elections On March 20</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://greatneckrecord.com/author/saj/">Sheri ArbitalJacoby</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-16T06:12:48+00:00" >March 16, 2018</time></span><div class="td-post-comments"><a href="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/#respond"><i class="td-icon-comments"></i>0</a></div><div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-37709">63</span></div></div></header></div><div class="td-post-sharing td-post-sharing-top "><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Six+Villages+To+Hold+Elections+On+March+20&url=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F&via=Great+Neck+Record"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/&amp;media=http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif&description=Six+Villages+To+Hold+Elections+On+March+20" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Six+Villages+To+Hold+Elections+On+March+20%20-%20http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" ><i class="td-icon-whatsapp"></i></a></div></div><div class="td-post-content"><div class="td-a-rec td-a-rec-id-content_top  "><div id='div-gpt-ad-1497370821859-2' style='height:90px; width:728px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1497370821859-2'); });</script> </div></div><p class="p5">Voters will head to the polls in the villages of Great Neck Estates, Great <span class="s2">Neck Plaza, Kensington, Russell </span>Gardens, Saddle Rock and Thomaston on Tuesday, March 20, as two mayors are up for reelection, two trustees in each village will be selected and two village justices are on the ballot. All of the races are uncontested.</p><p class="p5">Poll times and locations for each village are listed below.</p><p class="p5"><span class="s3">Candidates were invited to contrib</span>ute biographical information, and the <span class="s3">backgrounds of those who submitted information follow.</span></p><p class="p6"><b>Great Neck Estates</b></p><p class="p5"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckEstatesPark.jpg"><img class="alignright size-medium wp-image-37656" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckEstatesPark-300x267.jpg" alt="" width="300" height="267" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckEstatesPark-300x267.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckEstatesPark-472x420.jpg 472w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckEstatesPark.jpg 550w" sizes="(max-width: 300px) 100vw, 300px" /></a>The general election of the Village of Great Neck Estates will be held <span class="s2">from noon to 9 p.m. at Great Neck Estates Village Hall, located at Atwater Plaza, 4 Gateway Dr. </span></p><p class="p5">Two trustees will be on the ballot for terms of two years each.</p><p class="p5">The candidates are incumbents Howard S. Hershenhorn and Lanny Oppenheim.</p><p class="p6"><b>Great Neck Plaza </b></p><p class="p5">The Village of Great Neck Plaza election will be held from 9 a.m. to <span class="s2">9 p.m. at Village Hall, located at 2 Gussack Plaza.</span></p><p class="p5"><span class="s2"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza.jpg"><img class="size-medium wp-image-37657 alignleft" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-300x69.jpg" alt="" width="300" height="69" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-300x69.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-768x176.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-1024x234.jpg 1024w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-696x159.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-GreatNeckPlaza-1068x244.jpg 1068w" sizes="(max-width: 300px) 100vw, 300px" /></a>One mayor and two trustee </span>positions are up for election; each are two-year terms.</p><p class="p5"><span class="s4">Jean A. Celender is running for reelection for her 10th term as mayor, and Ted M. Rosen and Pamela A. Marksheid are seeking reelection as trustees. </span></p><p class="p7"><b>Kensington</b></p><p class="p5">Village of Kensington elections will be held from noon to 9 p.m. at Village Hall, located at 2 Nassau Dr.</p><p class="p5"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington.jpg"><img class="alignright size-medium wp-image-37658" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-300x200.jpg" alt="" width="300" height="200" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-300x200.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-768x512.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-1024x683.jpg 1024w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-696x464.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-1068x712.jpg 1068w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington-630x420.jpg 630w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Kensington.jpg 1375w" sizes="(max-width: 300px) 100vw, 300px" /></a>The positions being filled are for one mayor for a two-year term; two trustees, each for a two-year term; and one village justice for a term of four years.</p><p class="p5"><span class="s3">Susan Lopatkin, who has served as </span><span class="s1">mayor for 10 years, is seeking reelection, </span><span class="s2">Neil B. Garfinkel and incumbent </span><span class="s3">Jeffrey Greener are running for trustee </span><span class="s2">seats and incumbent Richard A. </span><span class="s3">Dennett is running for village justice.</span></p><p class="p8"><b>Russell Gardens </b></p><p class="p5"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens.jpg"><img class="size-medium wp-image-37659 alignleft" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens-300x300.jpg" alt="" width="300" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens-300x300.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens-150x150.jpg 150w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens-420x420.jpg 420w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-RussellGardens.jpg 553w" sizes="(max-width: 300px) 100vw, 300px" /></a>The Village of Russell Gardens election will be held from noon to 9 p.m. at Village Hall, located at 6 Tain Dr.</p><p class="p5">Two trustee positions, each for two-year terms, and one village justice, for a four-year term, will be selected.</p><p class="p5">Matthew Ellis and David Miller are running for reelection as trustees and Allen Cohen is running for reelection as village justice.</p><p class="p9"><b><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-SaddleRock.jpg"><img class="alignright size-medium wp-image-37660" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-SaddleRock-300x300.jpg" alt="" width="300" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-SaddleRock-300x300.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-SaddleRock-150x150.jpg 150w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-SaddleRock.jpg 306w" sizes="(max-width: 300px) 100vw, 300px" /></a>Saddle Rock</b></p><p class="p5">Village of Saddle Rock elections will be held from noon to 8 p.m. at Village Hall, located at 18 Masefield Way.</p><p class="p5"><span class="s2">Two trustee positions are up for </span>election, each for a two-year term.</p><p class="p5">Incumbent Kamran Barelli is seeking reelection for one trustee position and Ronen Ben-Josef is running for the other trustee seat.</p><p class="p10"><b>Thomaston </b></p><p class="p5"><span class="s3"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Thomaston.jpg"><img class="size-medium wp-image-37661 alignleft" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Thomaston-300x192.jpg" alt="" width="300" height="192" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Thomaston-300x192.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ELECTION-Thomaston.jpg 555w" sizes="(max-width: 300px) 100vw, 300px" /></a>The Village of Thomaston election will be held from noon to 9 p.m. at </span><span class="s1">Village Hall, located at 100 East Shore Rd.</span></p><p class="p5">Two trustee seats, each for a two-year term, are on the ballot.</p><p class="p5"><span class="s2">Incumbents To-on Pang and James E. Sharkey are running for the trustee positions.</span></p><p class="p5">Elections for the villages of Great <span class="s1">Neck, Kings Point and Lake Success will be held on Tuesday, June 19.</span></p><hr /><p class="p1"><b>Jean A. Celender For Great Neck Plaza Mayor</b></p><figure id="attachment_37662" style="max-width: 214px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaJean-CelenderA.jpg"><img class="size-medium wp-image-37662" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaJean-CelenderA-214x300.jpg" alt="" width="214" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaJean-CelenderA-214x300.jpg 214w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaJean-CelenderA-300x420.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaJean-CelenderA.jpg 660w" sizes="(max-width: 214px) 100vw, 214px" /></a><figcaption class="wp-caption-text">Jean A. Celender</figcaption></figure><p class="p2">It has been an honor and a privilege for Jean Celender, who is running for her 10th term as mayor, to serve as mayor of the Village of Great Neck Plaza, and she looks forward to continuing her service to the residents of the plaza. She has lived in a cooperative apartment on Overlook Avenue in Great Neck Plaza for 39 years with her husband, Jeffrey Schwartz. The couple has a grown daughter, Erin.</p><p class="p2">Jean has served in village government in various positions, including trustee and deputy mayor, since her arrival in the plaza. She is the chairperson of the Vigilant Fire Company Liaison Committee, the village’s taxi commissioner and serves as a director on the Water Authority of Great Neck North, Great Neck Village <span class="s1">Officials Association (treasurer), </span>Executive Committee of the Nassau County Village Officials Association (second vice president), Great Neck Plaza Business Improvement District, Great Neck Chamber of Commerce, Gold Coast Arts Center and CLASP Children’s Center. She has 39 years of experience in planning and environ-<span class="s1">mental consulting, community </span>outreach services and transportation planning. She earned a Master of Arts in Geography with a specialization in urban planning and a Bachelor of Arts in Geography/Cartography.</p><p class="p2">She is proud of the many initiatives and programs instituted during her tenure to increase the plaza’s livability, walkability and to provide affordable (workforce) housing, as well as doing the plaza’s part to reduce greenhouse gas emissions and reduce the effects of climate change on the environment, including adopting a Climate Action Plan and implementing programs such as the installation of a public electric vehicle charging station at Village Hall and the replacement of outdated, inefficient high-pressure sodium lighting in the two parking garages with efficient, maintenance-free LED fixtures, lowering the village’s carbon footprint in the process. As the first village in the U.S. to join the AARP Livable Communities Program, Great Neck Plaza is continuing initiatives to make it a more walkable, livable, socially connected and thriving community for residents of all ages and abilities.</p><p class="p2">Under her leadership, the Village Board adopted transit-oriented development in 2011 as a zoning change and revitalization initiative, <span class="s2">following the Great National Recession </span>in 2009, to permit mixed uses, mixed incomes, such as affordable apartments above first floor retail space, to attract and retain residents, especially <span class="s3">young professionals and empty nesters, </span>as an effective economic redevelopment initiative to bring vitality to the downtown—and she has worked tirelessly toward those goals.</p><p class="p2"><span class="s1">In the upcoming term, Jean looks forward to continuing these successful strategies and will endeavor to find other ways to preserve the plaza’s hometown feel and sense of community, while striving to develop and implement ways to balance growth and maintain quality of life. She wants to build upon her record of accomplishments on transportation and pedestrian-safety improvements by completing the </span>seventh traffic calming/infrastructure <span class="s1">“green” improvement program obtained through state and federal grants to enhance the Shoreward Drive/Welwyn Road area. This safety and beautification project, which will commence in the spring, will include reconstructed roadways with pedestrian-safety improvements, providing additional parking, new brick sidewalks, benches and street furniture, a public plaza with beautiful pavers and new trees and tree pits, and ornamental LED street lighting to increase safety at night for the many pedestrians and bicyclists who utilize this area to access the Great Neck train station and environs. </span></p><p class="p2"><span class="s4">The village also has plans to beautify the public alleyway—from the Gussack Plaza parking lot to Middle Neck Road—at 44 Middle Neck Rd., partnering with the plaza’s Business Improvement District and utilizing a downtown beautification grant obtained from the Town of North Hempstead. </span></p><p class="p2"><span class="s4">In her current term, the Maple Drive parking lot was redeveloped with permeable pavers and other green infrastructure techniques, Maple Drive was repaved, the first year of roadway repaving of 11 local streets in the multi-year State of Good Repair Program was completed and the benches and “pocket” park next to Maple Drive Garage was upgraded through grants received from the New York State Environmental Facilities Corporation and Nassau County Consortium’s Community Development Block Grant. </span></p><p class="p2">Jean believes that the village is best served by a strong, effective mayor with a proven track record and a forward vision to improve the village that has become reality. She has been fiscally responsible by proposing budgets that maintain property taxes at zero or minimal increases for the past eight out of nine years, as well as staying under the state’s real property tax cap. She will continue to work hard to deliver services, enhancements to the village and programs at the same high-quality levels. On March 20, she would appreciate plaza residents’ vote of confidence in her and her running mates, Trustees Ted Rosen and Pam Marksheid, in returning them to office to continue their important work.</p><p class="p2" style="text-align: right;"><i> —As submitted by the candidate</i></p><hr /><p class="p1"><b>Pamela A. Marksheid For Great Neck Plaza Trustee</b></p><figure id="attachment_37663" style="max-width: 200px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaPamela-MarksheidA.jpg"><img class="size-medium wp-image-37663" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaPamela-MarksheidA-200x300.jpg" alt="" width="200" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaPamela-MarksheidA-200x300.jpg 200w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaPamela-MarksheidA-280x420.jpg 280w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaPamela-MarksheidA.jpg 624w" sizes="(max-width: 200px) 100vw, 200px" /></a><figcaption class="wp-caption-text">Pamela A. Marksheid</figcaption></figure><p class="p2"><span class="s1">Pamela Marksheid, who is seeking her fifth term as trustee, has served as a Village of Great Neck Plaza trustee since 2008. She has lived in a Great Neck co-op for more than 25 years with her son, Sam. She became a member of the Board of Directors of 50 Brompton Owners Cooperative soon after moving into her three-building cooperative, and has served on the board for nearly 20 years, the last 15 years as president. She participated on the Shared Decision Making Committee for three years at South Middle School and also served as the parent chairperson. At South High School, she was the executive vice president and a member of the PTA’s board for several years. </span></p><p class="p2"><span class="s1">Pamela is retired from teaching in the New York City school system, where she was included in <i>Who’s Who Among America’s Teachers </i>three times. After retirement, she taught computer education and science at the Silverstein Hebrew Academy. She was a union activist for the New York City Teacher’s Union (UFT) and served for 25 years as a chapter leader. During that time, she was also a delegate to the American Federation of Teachers and New York State Federation of Teachers.</span></p><p class="p2"><span class="s1">Her service in local government came about through her active role in volunteering with the village and in other community-based organizations. Prior to her election as trustee, she served on the Zoning Board of Appeals for Great Neck Plaza. She has attended Town of North Hempstead meetings and has spoken out on issues that affect the plaza. She has also attended regular Great Neck Library meetings and, in her position as village trustee, helped champion the successful relocation of the Station Branch to an expanded location<br /> on the second floor of The Gardens at Great Neck shopping center. She spearheaded the drive to have this branch remain in the plaza and, together with fellow village officials, acted as intermediaries to help work out a solution between the landlord and the library. </span></p><p class="p2"><span class="s1">Pamela also serves as the trustee liaison to the Historic Preservation Commission and is a member of the Climate Smart Communities Committee, which is striving to receive certification by introducing initiatives to become more energy efficient. Pamela regularly attends the Nassau County Village Association’s monthly meetings, since it offers an understanding about what’s happening in other parts of the county and how it might affect Great Neck.</span></p><p class="p2"><span class="s1">Although the board only formally meets two Wednesdays a month, she and her fellow elected officials often meet on countless occasions for the betterment of the plaza. She receives great pleasure from the improvement in the safety of residents through the plaza’s numerous traffic calming projects, the continued beautification with huge seasonal flower planters and art displays and seeing thousands experiencing wonderful restaurants during Restaurant Weeks. The board has created a sense of community and showcased the village’s merchants during the summer months with its Street Promenades and music in the park series. </span></p><p class="p2"><span class="s1">Pamela approaches each issue with an open mind and has made decisions based on what will have a positive impact on the lives of the people who live in Great Neck Plaza. In this tough economic environment, she is proud of the board’s actions, working hard together and being fiscally prudent. In this year’s budget, the board has not had to go above the New York State tax cap and has kept the plaza’s property taxes at an almost zero increase during her tenure. This is certainly not typical of most municipalities. </span></p><p class="p2"><span class="s1">She greatly enjoys her work as a trustee, representing the people of Great Neck Plaza. It is not only an honor, but also a privilege. She hopes to continue serving the residents. </span></p><p class="p2" style="text-align: right;"><i> —As submitted by the candidate</i></p><hr /><p class="p1"><b>Ted M. Rosen For Great Neck Plaza Trustee</b></p><figure id="attachment_37664" style="max-width: 206px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA.jpg"><img class="size-medium wp-image-37664" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-206x300.jpg" alt="" width="206" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-206x300.jpg 206w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-768x1118.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-704x1024.jpg 704w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-696x1013.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA-289x420.jpg 289w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionGNPlazaTedMRosenA.jpg 786w" sizes="(max-width: 206px) 100vw, 206px" /></a><figcaption class="wp-caption-text">Ted M. Rosen</figcaption></figure><p class="p2"><span class="s1">A Great Neck Plaza resident since 1974, Ted Rosen lives in the Wyngate section of Great Neck Plaza with his wife, Nancy. The couple has two grown children, Melissa and Seth, and three grandchildren, Phoenix, Tristan and Freyja.</span></p><p class="p2"><span class="s1">A graduate of Queens College and New York University School of Law, Ted has been practicing law since 1973, primarily in commercial litigation in state and federal courts. He has substantial experience with the legal issues involved in the management of condominiums and cooperatives and has substantial experience as arbitrator for a number of different organizations and institutions. He has also served as a mediator, an administrative law judge and a hearing officer. Since 2006, he has been a full-time faculty member at Queensborough Community College. He is an associate professor, teaching business law and business organization and management. Previously, he coached the college’s mock trial team, which he started. Ted is a member and the secretary of the college’s Faculty Executive Committee and a member of the college’s Academic Freedom Committee.</span></p><p class="p2"><span class="s1">As a trustee and deputy mayor, he is the village’s cable commissioner, a member of the Great Neck/North Shore Cable Commission and a member and the secretary of the PATV Board of Directors. He supervises the Village’s Code Enforcement Unit, the Building Department, the Housing Department and helps supervise the Village’s Department of Public Works. Ted has also chaired, cochaired or served as a liaison to various village committees. He </span>worked to bring Holocaust memorial <span class="s2">programs, poetry readings and safety </span><span class="s1">seminars to the village.</span></p><p class="p2"><span class="s2">For 20 years, he was a member of the Nassau County Auxiliary Police, serving as a deputy inspector and chief of the Great Neck Central Auxiliary Police. Active in the Great Neck unit of the Police Activity League (PAL), he has served as a coach, grade coordinator, league commissioner, board member and trustee. He was one of several people responsible for the construction of the PAL building at Memorial Field. Previously, he served as a member of the Board of Directors of COPAY.</span></p><p class="p2"><span class="s1">Ted has been integrally involved in all aspects of village government </span><span class="s2">and knows how village government </span><span class="s1">works. He knows that success in all levels of government, particularly </span><span class="s2">at the local level, is achieved through </span>hard work and reaching a consensus. <span class="s1">He works constructively with his colleagues on the board, to build consensus, even when they may initially disagree, to obtain results that are in the best interests of the village and the public they serve.</span></p><p class="p2">The plaza faces various challenging <span class="s2">issues. First, is maintaining the high level of municipal services the village provides in the most cost-effective and fiscally responsible manner. He will continue to carefully examine every dollar the village spends and continue to support efforts to obtain grant monies for projects. </span><span class="s1">Second, is maintaining a vibrant </span><span class="s2">and active downtown by attracting new businesses and by finding new ways to promote and market the plaza. Third, is continuing to work to improve traffic and pedestrian safety through site-specific professional engineering projects and continuing to support efforts to obtain grant monies to pay most of the expenses of these projects.</span></p><p class="p2"><span class="s3">It has been his privilege and honor to serve the residents of Great Neck Plaza and to help make Great Neck Plaza an excellent place to live, work and shop. Ted hopes that with the support of plaza residents, he will have the opportunity to continue to do so. </span></p><p class="p2" style="text-align: right;"><i> —As submitted by the candidate</i></p><hr /><p class="p1"><b>Susan Lopatkin For Kensington Mayor</b></p><figure id="attachment_37667" style="max-width: 225px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA.jpg"><img class="size-medium wp-image-37667" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-225x300.jpg" alt="" width="225" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-225x300.jpg 225w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-768x1024.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-696x928.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-1068x1424.jpg 1068w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonSusanLopatkinA-315x420.jpg 315w" sizes="(max-width: 225px) 100vw, 225px" /></a><figcaption class="wp-caption-text">Susan Lopatkin</figcaption></figure><p class="p2">Susan Lopatkin, who is running for her sixth term as mayor, has been a resident of the Village of Kensington since 1994 and has served as mayor <span class="s1">since 2008. Before serving as mayor, </span>she was the chairperson of the Zoning Board, deputy mayor, pool commissioner and executive board member of the Kensington Civic Organization. <span class="s1">Currently, she also serves as vice president of the Great Neck Village Officials Association, having served previously as its president, and is </span>on the Board of Directors of the Water Authority of Great Neck North.</p><p class="p2"><span class="s2">Susan’s tenure as mayor is marked by her strong belief in fiscal conservativism, coupled with her commitment </span><span class="s1">to maintaining the beauty and </span><span class="s2">uniqueness of the village. Highlights of her achievements include a village centennial celebration, replacing all </span>village street and entrance signs with a <span class="s2">uniform design, restoration of the iconic “Kensington gates,” including lighting and landscaping, repaving all roads, upgrading the pool facility and overhauling the zoning code and building department policies. </span></p><p class="p2"><span class="s3">She is a strong supporter of the village police department and recently initiated a full renovation of police headquarters for the first time in more than 50 years. Most noteworthy, she has accomplished all of this while remaining within the New York State mandated 2 percent tax cap each year. Susan believes that there is still more work to be done, including continuing the restoration and upgrades to the many village islands, as well as the village green. </span></p><p class="p2"><span class="s3">Given the large amount of construction and renovation in the village, Susan is planning to review the current zoning and building department procedures to enhance the experience of the applicants and create a more streamlined approach for simpler applications. Her goal is to continue the high level of quality construction in the village.</span></p><p class="p2">Susan has enjoyed these last 10 years, working with a very committed board of trustees including current Deputy Mayor Darren Kaplan, prior Deputy Mayor Philip Bornstein (who is stepping down from the board this year) and trustees Alina Hendler and Jeffrey Greener. It takes a village to raise a child—and a dedicated board of trustees to run a village.</p><p class="p2"><span class="s3">Professionally, Susan is the principal </span><span class="s1">of her own firm, Comprehensive </span><span class="s3">Financial Strategies, providing retirement and estate planning services. She holds insurance and securities licenses and is a Certified Financial Planner and Certified Public Accountant. She is grateful for the support of her husband, Bob, and her two wonderful daughters, Stefanie and Allison. </span></p><p class="p2" style="text-align: right;"><i> —As submitted by the candidate</i></p><hr /><p class="p1"><b>Neil Garfinkel For Kensington Trustee</b></p><figure id="attachment_37666" style="max-width: 300px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA.jpg"><img class="size-medium wp-image-37666" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA-300x300.jpg" alt="" width="300" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA-300x300.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA-150x150.jpg 150w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA-420x420.jpg 420w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonNeil-GarfinkelA.jpg 660w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Neil Garfinkel</figcaption></figure><p class="p2"><span class="s1">Neil Garfinkel has lived in Great Neck since 1989 and in the Village of Kensington since 1998. </span></p><p class="p2"><span class="s1">After serving on the Kensington Zoning Board of Appeals for the past five years, Neil decided that he would like to become more involved with the village, saying, “I am impressed by the accomplishments of the mayor and the trustees, and the many things they do to ensure that our village remains a wonderful </span>place to live. As a longtime resident, <span class="s1">I feel that I should do my share to assist in maintaining our village.”</span></p><p class="p2"><span class="s1">Neil is a real estate and banking lawyer and is the managing partner of Abrams Garfinkel Margolis Bergson, LLP, a full-service law firm that has offices in Long Island, Manhattan and California. He believes that his real estate experience and the skills that he has learned by managing a medium-size law firm will translate well in his role as a village trustee.</span></p><p class="p2">Neil and his wife, Shari, have two adult children, Alyssa and Joshua, who both graduated from Great Neck South High School. The couple belongs to Temple Israel and Fresh Meadow Golf Club. Neil is a former president of the Little Neck Jewish Center and Shari is a former president of the Kochavim Group of Hadassah.</p><p class="p2" style="text-align: right;"><i> —As submitted by the candidate</i></p><hr /><p class="p1"><b>Jeffrey Greener For Kensington Trustee</b></p><figure id="attachment_37665" style="max-width: 292px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA.jpg"><img class="size-medium wp-image-37665" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-292x300.jpg" alt="" width="292" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-292x300.jpg 292w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-768x788.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-356x364.jpg 356w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-696x715.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA-409x420.jpg 409w, http://greatneckrecord.com/wp-content/uploads/2018/03/ElectionKensingtonJeffreyGreenerA.jpg 938w" sizes="(max-width: 292px) 100vw, 292px" /></a><figcaption class="wp-caption-text">Jeffrey Greener</figcaption></figure><p class="p2">Jeffrey Greener, who is running for <span class="s1">his fourth term as village trustee, has been a Kensington Village resident for </span>16 years and a Great Neck resident for more than 25 years.</p><p class="p2"><span class="s2">Jeff is chairman of the Trusts &amp; Estates Practice Group at Rivkin Radler LLP, headquartered in Uniondale, and serves on the firm’s executive committee. He is past national chairman and board member of the Alzheimer’s Foundation of America.</span></p><p class="p2"><span class="s3">He considers it an honor to continue representing the residents of the village </span><span class="s1">under the fiscally prudent guidance of Mayor Lopatkin and the dedicated trustees and staff of the village.</span></p><p class="p2" style="text-align: right;"><i>—As submitted by the candidate</i></p><p class="p2" style="text-align: right;"></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Six+Villages+To+Hold+Elections+On+March+20&url=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F&via=Great+Neck+Record"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/&amp;media=http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif&description=Six+Villages+To+Hold+Elections+On+March+20" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Six+Villages+To+Hold+Elections+On+March+20%20-%20http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" ><i class="td-icon-whatsapp"></i></a></div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" data-text="Six Villages To Hold Elections On March 20" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://greatneckrecord.com/chinese-community-thanks-social-center/">Chinese Community Thanks Social Center</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/">Seventh Annual Row For Autism Regatta To Take Place April 15</a></div></div></div><div class="author-box-wrap"><a href="http://greatneckrecord.com/author/saj/"><img width="96" height="96" src="http://greatneckrecord.com/wp-content/uploads/2017/01/SheriArbitalJacobyheadshot-150x150.jpg" class="avatar avatar-96 photo" alt="" srcset="http://greatneckrecord.com/wp-content/uploads/2017/01/SheriArbitalJacobyheadshot-150x150.jpg 150w, http://greatneckrecord.com/wp-content/uploads/2017/01/SheriArbitalJacobyheadshot-300x300.jpg 300w, http://greatneckrecord.com/wp-content/uploads/2017/01/SheriArbitalJacobyheadshot.jpg 341w" sizes="(max-width: 96px) 100vw, 96px" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://greatneckrecord.com/author/saj/">Sheri ArbitalJacoby</a></span></div><div class="td-author-description">Sheri ArbitalJacoby brings more than three decades of publishing experience at national magazines to her position as editor of the <em>Great Neck Record</em></a>. She also writes decorating, travel, food and green articles for <em>Long Island Weekly</em></a> and Anton Media Group's special sections.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Sheri ArbitalJacoby"></span><meta itemprop="datePublished" content="2018-03-16T06:12:48+00:00"><meta itemprop="dateModified" content="2018-03-13T12:54:52+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg"></span><meta itemprop="name" content="Great Neck Record"></span><meta itemprop="headline " content="Six Villages To Hold Elections On March 20"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif"><meta itemprop="width" content="300"><meta itemprop="height" content="300"></span></footer></article><div class="td_block_wrap td_block_related_posts td_uid_4_5aabf68aa49dc_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_4_5aabf68aa49dc" ><script>var block_td_uid_4_5aabf68aa49dc = new tdBlock();
block_td_uid_4_5aabf68aa49dc.id = "td_uid_4_5aabf68aa49dc";
block_td_uid_4_5aabf68aa49dc.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5aabf68aa49dc_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5aabf68aa49dc_rand","live_filter":"cur_post_same_categories","live_filter_cur_post_id":37709,"live_filter_cur_post_author":"30","block_template_id":""}';
block_td_uid_4_5aabf68aa49dc.td_column_number = "3";
block_td_uid_4_5aabf68aa49dc.block_type = "td_block_related_posts";
block_td_uid_4_5aabf68aa49dc.post_count = "3";
block_td_uid_4_5aabf68aa49dc.found_posts = "3123";
block_td_uid_4_5aabf68aa49dc.header_color = "";
block_td_uid_4_5aabf68aa49dc.ajax_pagination_infinite_stop = "";
block_td_uid_4_5aabf68aa49dc.max_num_pages = "1041";
tdBlocksArray.push(block_td_uid_4_5aabf68aa49dc);</script><h4 class="td-related-title td-block-title"><a id="td_uid_5_5aabf68aad653" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_5aabf68aa49dc" href="#">RELATED ARTICLES</a><a id="td_uid_6_5aabf68aad6a9" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_5aabf68aa49dc" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_5aabf68aa49dc class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/" rel="bookmark" title="Seventh Annual Row For Autism Regatta To Take Place April 15"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-218x150.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-218x150.jpg 218w, http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Seventh Annual Row For Autism Regatta To Take Place April 15"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/" rel="bookmark" title="Seventh Annual Row For Autism Regatta To Take Place April 15">Seventh Annual Row For Autism Regatta To Take Place April 15</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/chinese-community-thanks-social-center/" rel="bookmark" title="Chinese Community Thanks Social Center"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-218x150.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-218x150.jpg 218w, http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Chinese Community Thanks Social Center"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/chinese-community-thanks-social-center/" rel="bookmark" title="Chinese Community Thanks Social Center">Chinese Community Thanks Social Center</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/marilyn-schwab-henry-89/" rel="bookmark" title="Marilyn Schwab Henry, 89"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-218x150.jpeg" srcset="http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-218x150.jpeg 218w, http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Marilyn Schwab Henry, 89"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/marilyn-schwab-henry-89/" rel="bookmark" title="Marilyn Schwab Henry, 89">Marilyn Schwab Henry, 89</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5aabf68aa49dc" data-td_block_id="td_uid_4_5aabf68aa49dc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5aabf68aa49dc" data-td_block_id="td_uid_4_5aabf68aa49dc"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/six-villages-to-hold-elections-on-march-20/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&#038;postid=37709&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.9&#038;sig=059510df0c82aaa4ed8f4b1b200ada6fa708f03d#parent=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe> <!--[if !IE]><!--> <script>document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});</script> <!--<![endif]--></form></div> <input type="hidden" name="comment_parent" id="comment_parent" value="" /></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td_block_wrap td_block_7 td_block_widget td_uid_7_5aabf68ab2a60_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_7_5aabf68ab2a60" ><style>body .td_uid_7_5aabf68ab2a60_rand .td_module_wrap:hover .entry-title a,
            body .td_uid_7_5aabf68ab2a60_rand .td-pulldown-filter-link:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-subcat-item a:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-subcat-item .td-cur-simple-item,
            body .td_uid_7_5aabf68ab2a60_rand .td_quote_on_blocks,
            body .td_uid_7_5aabf68ab2a60_rand .td-opacity-cat .td-post-category:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-opacity-read .td-read-more a:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-opacity-author .td-post-author-name a:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-instagram-user a {
                color: #000000;
            }

            body .td_uid_7_5aabf68ab2a60_rand .td-next-prev-wrap a:hover,
            body .td_uid_7_5aabf68ab2a60_rand .td-load-more-wrap a:hover {
                background-color: #000000;
                border-color: #000000;
            }

            body .td_uid_7_5aabf68ab2a60_rand .block-title > *,
            body .td_uid_7_5aabf68ab2a60_rand .td-trending-now-title,
            body .td_uid_7_5aabf68ab2a60_rand .td-read-more a,
            body .td_uid_7_5aabf68ab2a60_rand .td-weather-information:before,
            body .td_uid_7_5aabf68ab2a60_rand .td-weather-week:before,
            body .td_uid_7_5aabf68ab2a60_rand .td-subcat-dropdown:hover .td-subcat-more,
            body .td_uid_7_5aabf68ab2a60_rand .td-exchange-header:before,
            body .td-footer-wrapper .td_uid_7_5aabf68ab2a60_rand .td-post-category,
            body .td_uid_7_5aabf68ab2a60_rand .td-post-category:hover {
                background-color: #000000;
            }
            body .td-footer-wrapper .td_uid_7_5aabf68ab2a60_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            body .td_uid_7_5aabf68ab2a60_rand .block-title {
                border-color: #000000;
            }</style><script>var block_td_uid_7_5aabf68ab2a60 = new tdBlock();
block_td_uid_7_5aabf68ab2a60.id = "td_uid_7_5aabf68ab2a60";
block_td_uid_7_5aabf68ab2a60.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"221","category_ids":"","custom_title":"Featured","custom_url":"greatneckrecord.com\/category\/featured","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#000000","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_7_5aabf68ab2a60_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_7_5aabf68ab2a60_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_7_5aabf68ab2a60.td_column_number = "1";
block_td_uid_7_5aabf68ab2a60.block_type = "td_block_7";
block_td_uid_7_5aabf68ab2a60.post_count = "5";
block_td_uid_7_5aabf68ab2a60.found_posts = "1886";
block_td_uid_7_5aabf68ab2a60.header_color = "#000000";
block_td_uid_7_5aabf68ab2a60.ajax_pagination_infinite_stop = "";
block_td_uid_7_5aabf68ab2a60.max_num_pages = "378";
tdBlocksArray.push(block_td_uid_7_5aabf68ab2a60);</script><div class="td-block-title-wrap"><h4 class="block-title"><a href="http://greatneckrecord.com/category/featured" class="td-pulldown-size">Featured</a></h4></div><div id=td_uid_7_5aabf68ab2a60 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/" rel="bookmark" title="Seventh Annual Row For Autism Regatta To Take Place April 15"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/DSC_9652-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Seventh Annual Row For Autism Regatta To Take Place April 15"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/seventh-annual-row-for-autism-regatta-to-take-place-april-15/" rel="bookmark" title="Seventh Annual Row For Autism Regatta To Take Place April 15">Seventh Annual Row For Autism Regatta To Take Place April 15</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-16T12:15:38+00:00" >March 16, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" rel="bookmark" title="Six Villages To Hold Elections On March 20"><img width="70" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2014/12/voteWEB.gif" alt="" title="Six Villages To Hold Elections On March 20"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/six-villages-to-hold-elections-on-march-20/" rel="bookmark" title="Six Villages To Hold Elections On March 20">Six Villages To Hold Elections On March 20</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-16T06:12:48+00:00" >March 16, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/chinese-community-thanks-social-center/" rel="bookmark" title="Chinese Community Thanks Social Center"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/GNSC-A-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Chinese Community Thanks Social Center"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/chinese-community-thanks-social-center/" rel="bookmark" title="Chinese Community Thanks Social Center">Chinese Community Thanks Social Center</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-15T06:12:59+00:00" >March 15, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/marilyn-schwab-henry-89/" rel="bookmark" title="Marilyn Schwab Henry, 89"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-100x70.jpeg" srcset="http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-100x70.jpeg 100w, http://greatneckrecord.com/wp-content/uploads/2016/05/Obituary-Featured-Image-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Marilyn Schwab Henry, 89"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/marilyn-schwab-henry-89/" rel="bookmark" title="Marilyn Schwab Henry, 89">Marilyn Schwab Henry, 89</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-14T06:12:19+00:00" >March 14, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/south-high-students-to-participate-in-national-walkout/" rel="bookmark" title="South High Students To Participate In National Walkout"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/WalkoutA-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/WalkoutA-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/WalkoutA-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="South High Students To Participate In National Walkout"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/south-high-students-to-participate-in-national-walkout/" rel="bookmark" title="South High Students To Participate In National Walkout">South High Students To Participate In National Walkout</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-13T13:26:11+00:00" >March 13, 2018</time></span></div></div></div></div></div></div><div class="td-a-rec td-a-rec-id-custom_ad_1  "><div id='div-gpt-ad-1463590303247-4' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-4'); });</script> </div></div><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Great Neck Area News</span></h4><div class="textwidget"><div id="w6897_widget"></div><script language="JavaScript" src="http://tools.prnewswire.com/en-us/live/6897/widget.js"></script> </div></aside><div class="td-a-rec td-a-rec-id-custom_ad_3  "><div id='div-gpt-ad-1463590303247-5' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-5'); });</script> </div></div><aside class="td_block_template_1 widget widget_rss"><h4 class="block-title"><span><a class="rsswidget" href="https://longislandweekly.com/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://greatneckrecord.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://longislandweekly.com/">Long Island Weekly</a></span></h4><ul><li><a class='rsswidget' href='https://longislandweekly.com/dixie-dregs-rise-again/'>Dixie Dregs Rise Again</a></li><li><a class='rsswidget' href='https://longislandweekly.com/steve-morse-of-the-dixie-dregs-fave-guitarists/'>Steve Morse Of The Dixie Dregs’ Fave Guitarists</a></li><li><a class='rsswidget' href='https://longislandweekly.com/former-tonh-employee-sentenced-for-embezzling-nearly-100000/'>Former TONH Employee Sentenced For Embezzling Nearly $100,000</a></li><li><a class='rsswidget' href='https://longislandweekly.com/explore-the-south-shore-of-long-island-on-the-water/'>Explore The South Shore Of Long Island On The Water</a></li><li><a class='rsswidget' href='https://longislandweekly.com/long-islands-perri-nemiroff-produces-a-career-in-the-film-industry/'>Long Island’s Perri Nemiroff Produces A Career In The Film Industry</a></li></ul></aside></div></div></div></div></div><div class="td-footer-wrapper td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-a-rec td-a-rec-id-footer_top  "><div id='div-gpt-ad-1463590303247-2' style='height:90px; width:728px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-2'); });</script> </div></div></div></div><div class="td-pb-row"><div class="td-pb-span12"></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://greatneckrecord.com/"><img src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogoGray.jpg" alt="Great Neck Record" title="Great Neck Record"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Since 1908, <em>Great Neck Record</em> has served the communities of Great Neck, Great Neck Estates, Great Neck Plaza, Kensington, Kings Point, Lake Success, Russell Gardens, Saddle Rock, Thomaston and the unincorporated areas as a source for local news and community events.<div class="footer-email-wrap">Contact us: <a href="mailto:greatneck@antonmediagroup.com">greatneck@antonmediagroup.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GreatNeckRecord/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://plus.google.com/b/117482670940543624944" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/greatneckrecord" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright 2017 • Anton Media Group • All Rights Reserved</div></div></div></div></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <div style="display:none"><div class="grofile-hash-map-86c00f575211c7e5ece51978f58b2e6c"></div></div> <style type="text/css" media="screen">/* custom css theme panel */
.vc_single_image a {
    width: 100%;
    display: block;
    background-size: contain !important;
    background-repeat: no-repeat;
}</style> <script type='text/javascript'>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};</script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201811'></script> <script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Maraa'></script> <script type='text/javascript'>var WPGroHo = {"my_hash":""};</script>  <script>(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://greatneckrecord.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://greatneckrecord.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();</script> <!--[if IE]> <script type="text/javascript">if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}</script> <![endif]--> <script type="text/javascript">(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&postid=37709&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=059510df0c82aaa4ed8f4b1b200ada6fa708f03d#parent=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&postid=37709&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=059510df0c82aaa4ed8f4b1b200ada6fa708f03d#parent=http%3A%2F%2Fgreatneckrecord.com%2Fsix-villages-to-hold-elections-on-march-20%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();</script> <script type='text/javascript' src='https://stats.wp.com/e-201811.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'35178715',post:'37709',tz:'-4',srv:'greatneckrecord.com'} ]);
	_stq.push([ 'clickTrackerInit', '35178715', '37709' ]);</script> <script type="text/javascript" defer src="http://greatneckrecord.com/wp-content/cache/autoptimize/js/autoptimize_1770657234176ec0f237d31acec4be00.js"></script></body></html>