<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><title>Local Students Lead Charge On Gun Control | Great Neck Record</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="http://greatneckrecord.com/xmlrpc.php" /><meta property="og:image" content="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png" /><link rel="icon" type="image/png" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-16x16.jpg"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-76x76.jpg"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-120x120.jpg"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-152x152.jpg"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-114x114.jpg"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://greatneckrecord.com/wp-content/uploads/2016/11/Great-Neck-144x144.jpg"/> <script type="text/javascript">var ajaxurl = 'http://greatneckrecord.com/wp-admin/admin-ajax.php';</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//s.gravatar.com' /><link rel='dns-prefetch' href='//maps.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Feed" href="http://greatneckrecord.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Comments Feed" href="http://greatneckrecord.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Great Neck Record &raquo; iCal Feed" href="http://greatneckrecord.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="Great Neck Record &raquo; Local Students Lead Charge On Gun Control Comments Feed" href="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/greatneckrecord.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='fvp-frontend-css'  href='http://greatneckrecord.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.0' type='text/css' media='all' /><link rel='stylesheet' id='js_composer_front-css'  href='http://greatneckrecord.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.1.1' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css'  href='http://greatneckrecord.com/wp-content/themes/Newspaper-child/style.css?ver=8.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://greatneckrecord.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' /> <script type='text/javascript' src='http://greatneckrecord.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript'>var fvpdata = {"ajaxurl":"http:\/\/greatneckrecord.com\/wp-admin\/admin-ajax.php","nonce":"728c977000","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};</script> <link rel='https://api.w.org/' href='http://greatneckrecord.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://greatneckrecord.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://greatneckrecord.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Erin Lipinsky Sets New Fundraising Record' href='http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/' /><meta name="generator" content="WordPress 4.9.4" /><link rel="canonical" href="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" /><link rel='shortlink' href='https://wp.me/p2nBAD-9Vj' /><link rel="alternate" type="application/json+oembed" href="http://greatneckrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" /><link rel="alternate" type="text/xml+oembed" href="http://greatneckrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F&#038;format=xml" /> <style type="text/css">div#map.slp_map {
width:100%;
height:480px;
}
div#slp_tagline {
width:100%;
}</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://greatneckrecord.com"><link rel="https://theeventscalendar.com/" href="http://greatneckrecord.com/wp-json/tribe/events/v1/" /><link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//jetpack.wordpress.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//s1.wp.com'/><link rel='dns-prefetch' href='//s2.wp.com'/><link rel='dns-prefetch' href='//public-api.wordpress.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://greatneckrecord.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta property="og:type" content="article" /><meta property="og:title" content="Local Students Lead Charge On Gun Control" /><meta property="og:url" content="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" /><meta property="og:description" content="History was made in Great Neck on March 24, as a much larger than expected crowd filled Jonathan L. Ielpi Firefighters Park on Grace Avenue for the March for Our Lives rally organized by North Shor…" /><meta property="article:published_time" content="2018-04-05T10:05:49+00:00" /><meta property="article:modified_time" content="2018-04-03T20:06:43+00:00" /><meta property="og:site_name" content="Great Neck Record" /><meta property="og:image" content="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png" /><meta property="og:image:width" content="586" /><meta property="og:image:height" content="438" /><meta property="og:locale" content="en_US" /><meta name="twitter:site" content="@GreatNeckRecord" /><meta name="twitter:text:title" content="Local Students Lead Charge On Gun Control" /><meta name="twitter:image" content="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png?w=640" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@GreatNeckRecord" />  <script>var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var td_ajax_url="http:\/\/greatneckrecord.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.0";
var td_get_template_directory_uri="http:\/\/greatneckrecord.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script> <style>ul.sf-menu > .td-menu-item > a {
        font-size:14px;
	font-weight:normal;
	
    }</style> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65941892-2', 'auto');
  ga('send', 'pageview');</script><script type="application/ld+json">{
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://greatneckrecord.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://greatneckrecord.com/category/news/",
                                "name": "Great Neck News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://greatneckrecord.com/local-students-lead-charge-on-gun-control/",
                                "name": "Local Students Lead Charge On Gun Control"                                
                            }
                        }    ]
                        }</script> <style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


@media (max-width: 767px){
.td-header-sp-top-menu {
    display: block !important; 
}
}
@media (max-width: 767px)
{
	.td-header-top-menu-full {
    display:  block !important;
}
}
.top_menu_space{top: 30px !important;}

.td-banner-wrap-full.td-logo-wrap-full.td-container-wrap{margin-top: 28px;}

.td-header-top-menu-full.td-container-wrap {position: fixed;
    width: 100%;
    top: 0px;} 
.td-header-menu-wrap.td-affix{top: 28px !important;}</style><noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script type='text/javascript'>(function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();</script> <script src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>googletag.cmd.push(function() {
    googletag.defineSlot('/33457410/1x1GreatN', [1, 1], 'div-gpt-ad-1497370821859-0').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_BottomRtRail', [300, 250], 'div-gpt-ad-1497370821859-1').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_Leader', [728, 90], 'div-gpt-ad-1497370821859-2').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_728x90_pgal', [728, 90], 'div-gpt-ad-1497370821859-3').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_ATF_Cube', [300, 250], 'div-gpt-ad-1497370821859-4').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeA', [300, 250], 'div-gpt-ad-1497370821859-5').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeB', [300, 250], 'div-gpt-ad-1497370821859-6').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });</script> <script type='text/javascript'>googletag.cmd.push(function() {
    googletag.defineSlot('/33457410/1x1GreatN', [1, 1], 'div-gpt-ad-1463590303247-0').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GreatN_InnerPage_Leader', [728, 90], 'div-gpt-ad-1463590303247-1').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_728x90_pgal', [728, 90], 'div-gpt-ad-1463590303247-2').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_Leader', [728, 90], 'div-gpt-ad-1463590303247-3').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_ATF_Cube', [300, 250], 'div-gpt-ad-1463590303247-4').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeA', [300, 250], 'div-gpt-ad-1463590303247-5').addService(googletag.pubads());
    googletag.defineSlot('/33457410/GN_int_CubeB', [300, 250], 'div-gpt-ad-1463590303247-6').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65941892-2', 'auto');
  ga('send', 'pageview');</script> </head><body class="post-template-default single single-post postid-38149 single-format-standard tribe-no-js local-students-lead-charge-on-gun-control global-block-template-1 wpb-js-composer js-comp-ver-5.1.1 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GreatNeckRecord/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://plus.google.com/b/117482670940543624944" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/greatneckrecord" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-368" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-368"><a href="http://greatneckrecord.com">Home</a></li><li id="menu-item-369" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-369"><a href="http://greatneckrecord.com/category/news/">Great Neck News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-21832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21832"><a href="http://greatneckrecord.com/category/fire-police/">Fire &#038; Police</a></li></ul></li><li id="menu-item-370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-370"><a href="http://greatneckrecord.com/events/">Events<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2299" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2299"><a href="http://greatneckrecord.com/events/">All Events</a></li></ul></li><li id="menu-item-429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-429"><a href="http://greatneckrecord.com/category/school-news/">School News</a></li><li id="menu-item-14001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14001"><a href="http://greatneckrecord.com/category/arts/">Arts</a></li><li id="menu-item-14002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14002"><a href="http://greatneckrecord.com/category/sports/">Sports</a></li><li id="menu-item-16221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16221"><a href="http://greatneckrecord.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-21836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21836"><a href="http://greatneckrecord.com/category/opinion/columns/">Columns</a></li><li id="menu-item-16222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16222"><a href="http://greatneckrecord.com/category/opinion/editorials/">Editorials</a></li><li id="menu-item-16223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16223"><a href="http://greatneckrecord.com/category/opinion/letters-to-editor/">Letters to the Editor</a></li></ul></li><li id="menu-item-13605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13605"><a href="http://greatneckrecord.com/category/great-neck-magazine/">Magazine<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2801"><a href="http://greatneckrecord.com/magazine/">Great Neck Magazine</a></li></ul></li><li id="menu-item-18150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18150"><a href="http://longislandweekly.com/category/specials/">Specials<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-18151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18151"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li><li id="menu-item-18152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18152"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li><li id="menu-item-18153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18153"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li><li id="menu-item-18154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18154"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li><li id="menu-item-18156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18156"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li><li id="menu-item-18157" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18157"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li><li id="menu-item-18159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18159"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li><li id="menu-item-18160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18160"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li><li id="menu-item-18161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18161"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li><li id="menu-item-33419" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33419"><a href="https://longislandweekly.com/category/specials/">More</a></li></ul></li><li id="menu-item-21834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-21834"><a href="http://greatneckrecord.com/#">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-26339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26339"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li><li id="menu-item-21833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21833"><a href="http://greatneckrecord.com/category/obituaries/">Obituaries</a></li><li id="menu-item-14042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14042"><a href="http://greatneckrecord.com/town-bulletin-board/">Important Info</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="http://greatneckrecord.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="td-header-wrap td-header-style-1"><div class="td-header-top-menu-full td-container-wrap  top_menu_space1"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-1"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-14007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-14007"><a href="http://antonnews.com">Edition</a><ul class="sub-menu"><li id="menu-item-24894" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24894"><a href="https://longislandweekly.com/">Long Island Weekly</a></li><li id="menu-item-24877" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24877"><a href="http://farmingdale-observer.com/">Farmingdale</a></li><li id="menu-item-24878" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24878"><a href="http://floralparkdispatch.com/">Floral Park</a></li><li id="menu-item-24879" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24879"><a href="http://gardencity-life.com/">Garden City</a></li><li id="menu-item-24880" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24880"><a href="http://glencoverecordpilot.com/">Glen Cove</a></li><li id="menu-item-24882" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24882"><a href="http://hicksvillenews.com/">Hicksville</a></li><li id="menu-item-24883" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24883"><a href="http://levittown-tribune.com/">Levittown ∙ Wantagh</a></li><li id="menu-item-24884" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24884"><a href="http://manhassetpress.com/">Manhasset</a></li><li id="menu-item-24885" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24885"><a href="http://www.massapequaobserver.com/">Massapequa</a></li><li id="menu-item-24886" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24886"><a href="http://mineolaamerican.com/">Mineola</a></li><li id="menu-item-24887" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24887"><a href="http://newhydeparkillustrated.com/">New Hyde Park</a></li><li id="menu-item-24888" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24888"><a href="http://oysterbayenterprisepilot.com/">Oyster Bay</a></li><li id="menu-item-24889" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24889"><a href="http://plainviewoldbethpageherald.com/">Plainview ∙ Old Bethpage</a></li><li id="menu-item-24890" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24890"><a href="http://portwashington-news.com/">Port Washington</a></li><li id="menu-item-24891" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24891"><a href="http://roslyn-news.com/">Roslyn ∙ Greenvale</a></li><li id="menu-item-24892" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24892"><a href="http://syossetjerichotribune.com/">Syosset ∙ Jericho</a></li><li id="menu-item-24893" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24893"><a href="http://thewestburytimes.com/">Westbury ∙ Carle Place</a></li></ul></li><li id="menu-item-33122" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33122"><a href="http://greatneckrecord.com/newsstands/">Newsstands</a></li><li id="menu-item-14004" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-14004"><a href="http://greatneckrecord.com/advertise-with-anton-newspapers/">Advertise</a></li><li id="menu-item-14005" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-14005"><a href="https://antonnews.com/subscription/">Subscribe</a></li><li id="menu-item-16694" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-16694"><a href="http://greatneckrecord.com/contact-us/">Contact Us</a></li><li id="menu-item-15221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-15221"><a href="http://greatneckrecord.com/newspaper-in-education/">Newspaper In Education</a><ul class="sub-menu"><li id="menu-item-22706" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-22706"><a href="https://longislandweekly.com/category/newspaper-in-education/">Lesson Plans</a></li></ul></li></ul></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap "><div class="td-container td-header-row td-header-header"><div class="td-header-sp-logo"> <a class="td-main-logo" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-544x180-300x99.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg" alt="Great Neck Record" title="Great Neck Record"/> <span class="td-visual-hidden">Great Neck Record</span> </a></div><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-a-rec td-a-rec-id-header  "><div id='div-gpt-ad-1463590303247-3' style='height:90px; width:728px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-3'); });</script> </div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap "><div class="td-header-menu-wrap td-header-gradient"><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-disable" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-280x96.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-140x48.jpg" alt="Great Neck Record" title="Great Neck Record"/> </a> <a class="td-header-logo td-sticky-disable" href="http://greatneckrecord.com/"> <img class="td-retina-data" data-retina="http://greatneckrecord.com/wp-content/uploads/2016/11/GreatNeck_WebLogo-544x180-300x99.jpg" src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg" alt="Great Neck Record" title="Great Neck Record"/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-368"><a href="http://greatneckrecord.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-369"><a href="http://greatneckrecord.com/category/news/">Great Neck News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21832"><a href="http://greatneckrecord.com/category/fire-police/">Fire &#038; Police</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-370"><a href="http://greatneckrecord.com/events/">Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-2299"><a href="http://greatneckrecord.com/events/">All Events</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-429"><a href="http://greatneckrecord.com/category/school-news/">School News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14001"><a href="http://greatneckrecord.com/category/arts/">Arts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14002"><a href="http://greatneckrecord.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-16221"><a href="http://greatneckrecord.com/category/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21836"><a href="http://greatneckrecord.com/category/opinion/columns/">Columns</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16222"><a href="http://greatneckrecord.com/category/opinion/editorials/">Editorials</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16223"><a href="http://greatneckrecord.com/category/opinion/letters-to-editor/">Letters to the Editor</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-13605"><a href="http://greatneckrecord.com/category/great-neck-magazine/">Magazine</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2801"><a href="http://greatneckrecord.com/magazine/">Great Neck Magazine</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-18150"><a href="http://longislandweekly.com/category/specials/">Specials</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18151"><a href="http://longislandweekly.com/category/specials/automotive/">Automotive</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18152"><a href="http://longislandweekly.com/category/specials/banking-finance/">Banking &#038; Finance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18153"><a href="http://longislandweekly.com/category/specials/camps-schools/">Camps &#038; Schools</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18154"><a href="http://longislandweekly.com/category/specials/education/">Education</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18156"><a href="http://longislandweekly.com/category/specials/healthy-living">Healthy Living</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18157"><a href="http://longislandweekly.com/category/specials/asa-house-home/">Home Design</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18159"><a href="http://longislandweekly.com/category/specials/senior-living/">Senior Living</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18160"><a href="http://longislandweekly.com/category/specials/vacation-travel/">Vacation &#038; Travel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-18161"><a href="http://longislandweekly.com/category/specials/wine-dine/">Wine &#038; Dine</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-33419"><a href="https://longislandweekly.com/category/specials/">More</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children td-menu-item td-normal-menu menu-item-21834"><a href="http://greatneckrecord.com/#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-26339"><a href="https://longislandweekly.com/category/classifieds/">Classifieds</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21833"><a href="http://greatneckrecord.com/category/obituaries/">Obituaries</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-14042"><a href="http://greatneckrecord.com/town-bulletin-board/">Important Info</a></li></ul></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="http://greatneckrecord.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://greatneckrecord.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Great Neck News" class="entry-crumb" href="http://greatneckrecord.com/category/news/">Great Neck News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Local Students Lead Charge On Gun Control</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-38149" class="post-38149 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news" itemscope itemtype="http://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="http://greatneckrecord.com/category/news/">Great Neck News</a></li></ul><header class="td-post-title"><h1 class="entry-title">Local Students Lead Charge On Gun Control</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://greatneckrecord.com/author/jacqueline-harounian/">Jacqueline Harounian</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-05T06:05:49+00:00" >April 5, 2018</time></span><div class="td-post-comments"><a href="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/#respond"><i class="td-icon-comments"></i>0</a></div><div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-38149">151</span></div></div></header></div><div class="td-post-sharing td-post-sharing-top "><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Local+Students+Lead+Charge+On+Gun+Control&url=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F&via=Great+Neck+Record"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://greatneckrecord.com/local-students-lead-charge-on-gun-control/&amp;media=http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png&description=Local+Students+Lead+Charge+On+Gun+Control" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Local+Students+Lead+Charge+On+Gun+Control%20-%20http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" ><i class="td-icon-whatsapp"></i></a></div></div><div class="td-post-content"><div class="td-a-rec td-a-rec-id-content_top  "><div id='div-gpt-ad-1497370821859-2' style='height:90px; width:728px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1497370821859-2'); });</script> </div></div><figure id="attachment_38072" style="max-width: 300px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchL.png"><img class="size-medium wp-image-38072" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchL-300x202.png" alt="" width="300" height="202" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchL-300x202.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchL.png 550w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">A crowd filled Jonathan L. Ielpi Firefighters Park.</figcaption></figure><p class="p5">History was made in Great Neck <span class="s1">on March 24, as a much larger </span>than expected crowd filled Jonathan L. Ielpi Firefighters Park on Grace Avenue for the March for Our Lives <span class="s1">rally organized by North Shore </span>Action and sponsored by a coalition of bipartisan and interfaith groups.</p><p class="p5">Nearly 500 people, who came out to enjoy the sun and support local students, teachers, clergy and community leaders, brought homemade and printed signs, orange ribbons and tremendous passion for the cause: to make our schools and society safer from the threat of gun violence.</p><figure id="attachment_38062" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchA.png"><img class="size-medium wp-image-38062" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchA-300x201.png" alt="" width="300" height="201" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchA-300x201.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchA.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">A crowd filled Jonathan L. Ielpi Firefighters Park.<br />(Photos by Jacqueline Harounian and Darren Kaplan)</figcaption></figure><p class="p5"><span class="s2">A new generation of students has become energized and empowered since the tragic mass shooting in Parkland, </span><span class="s3">FL. In the past six weeks, Great Neck </span><span class="s2">students have followed the lead of the survivors of the Feb. 14 tragedy by organizing walkouts and rallies, and raising their voices. Most of the student activists are not old enough to vote, buy a beer or rent a car, though in many states, they can easily obtain a firearm. </span></p><p class="p5">Young people are increasingly <span class="s1">vocal about how the prevalence of </span>gun violence is affecting their daily lives, especially at school, where their new reality includes “active shooter drills” on a regular basis, and the real fear and anxiety of becoming victims <span class="s1">themselves. The student activism has already changed gun laws in </span><span class="s3">several states and has persuaded giant </span>retailers, including Dick’s Sporting <span class="s3">Goods and Kroger, and major airlines, to stop selling guns and end ties with </span><span class="s1">the National Rifle Association (NRA). </span></p><figure id="attachment_38064" style="max-width: 225px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchC-The-names-of-victims-from-Parkland-Florida-shooting-on-Feb.-14.png"><img class="size-medium wp-image-38064" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchC-The-names-of-victims-from-Parkland-Florida-shooting-on-Feb.-14-225x300.png" alt="" width="225" height="300" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchC-The-names-of-victims-from-Parkland-Florida-shooting-on-Feb.-14-225x300.png 225w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchC-The-names-of-victims-from-Parkland-Florida-shooting-on-Feb.-14-316x420.png 316w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchC-The-names-of-victims-from-Parkland-Florida-shooting-on-Feb.-14.png 587w" sizes="(max-width: 225px) 100vw, 225px" /></a><figcaption class="wp-caption-text">The sign lists the names of the victims from the Feb. 14 Parkland, FL, shooting.</figcaption></figure><p class="p5"><span class="s2">Statistics show that 90 percent of people younger than 25 killed by guns in high-income countries are from the U.S. But even as mass-shooting deaths have escalated, the issue of gun control has remained a “third rail” issue because of the Second Amendment. </span></p><p class="p5"><span class="s4">Student activists are looking to elected </span><span class="s2">leaders to make a change. When it </span><span class="s1">comes to gun violence, they believe </span><span class="s2">it is time for action, not thoughts and prayers. Most Americans agree with </span><span class="s4">this sentiment, t</span><span class="s2">hough everyone does not agree on what form the action should take. Will it include a ban or restrictions on gun sales? National background </span>checks? Increased police protection <span class="s2">at schools? Now is the time to have the discussion and implement changes.</span></p><p class="p6"><b>Students Took Center Stage</b></p><figure id="attachment_38063" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchB-Great-Neck-Middle-School-Students-Hannah-Sutin-Sabrina-Namigohar-and-Joanne-Sarfati-recited-the-names-of-the-slain-Parkland-students.png"><img class="size-medium wp-image-38063" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchB-Great-Neck-Middle-School-Students-Hannah-Sutin-Sabrina-Namigohar-and-Joanne-Sarfati-recited-the-names-of-the-slain-Parkland-students-300x200.png" alt="" width="300" height="200" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchB-Great-Neck-Middle-School-Students-Hannah-Sutin-Sabrina-Namigohar-and-Joanne-Sarfati-recited-the-names-of-the-slain-Parkland-students-300x200.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchB-Great-Neck-Middle-School-Students-Hannah-Sutin-Sabrina-Namigohar-and-Joanne-Sarfati-recited-the-names-of-the-slain-Parkland-students.png 587w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Great Neck Middle schoolers Hannah Sutin, Sabrina Namigohar and Joanne Sarfati recited the names of the slain Parkland students.</figcaption></figure><p class="p5">Like the Parkland student activists we see every day on television, Great <span class="s2">Neck students are motivated, optimistic, </span>passionate and well informed. Their detractors may call them idealistic and even disrespectful, but the students are undeterred and united in their goal: to live in a better world and to go to safer schools, without the fear of violence. They believe their future is at stake and that the “adults in the room” have failed them.</p><p class="p5">After decades of ineffectual efforts <span class="s2">to pass gun-control legislation, many believe it is time to listen to the younger </span><span class="s1">generation. History has shown us </span>that social change is often effectuated <span class="s2">by youth movements that may appear </span><span class="s1">messy, imperfect and naive. But with </span>social media savvy and the energy of <span class="s2">millions of followers online, it seems that the cultural zeitgeist is moving towards real change, as recently displayed with #MeToo and other calls for reform. </span></p><figure id="attachment_38065" style="max-width: 300px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchE-Talia-Katz-Great-Neck-South-student-leader.png"><img class="size-medium wp-image-38065" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchE-Talia-Katz-Great-Neck-South-student-leader-300x200.png" alt="" width="300" height="200" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchE-Talia-Katz-Great-Neck-South-student-leader-300x200.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchE-Talia-Katz-Great-Neck-South-student-leader.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Talia Katz, a Great Neck South student leader, spoke.</figcaption></figure><p class="p5"><span class="s2">Talia Katz, a Great Neck South High School student leader, spoke with conviction about the need for gun control.</span></p><p class="p5"><span class="s2">“This is not a partisan issue. We just want to be safe,” said Katz. “This is not an attack on the constitution. This is a demand for our unalienable rights. Even though we are in high school, as citizens of this nation, we are still entitled to our rights to life, liberty and the pursuit of </span>happiness. These rights should not be <span class="s2">taken away from us in minutes or even seconds. In schools, the place where students should feel most safe, we now feel the most vulnerable. The school walls have begun to close in on many of us, and while we understand completely </span><span class="s1">it is for our safety, it is hard to forget that locking us in is not the answer. I believe guns are the problem. We can </span><span class="s2">no longer sit idly by while other people make decisions about our lives and we watch as our country continues </span>to have the highest mass-shooting <span class="s3">rates in the world. There is no topic as </span><span class="s2">important as the safety of our nation.” </span></p><figure id="attachment_38066" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchF-Oliver-Pour-high-school-senior-and-current-President-of-the-student-government-at-Great-Neck-North.png"><img class="size-medium wp-image-38066" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchF-Oliver-Pour-high-school-senior-and-current-President-of-the-student-government-at-Great-Neck-North-300x200.png" alt="" width="300" height="200" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchF-Oliver-Pour-high-school-senior-and-current-President-of-the-student-government-at-Great-Neck-North-300x200.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchF-Oliver-Pour-high-school-senior-and-current-President-of-the-student-government-at-Great-Neck-North.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Oliver Pour is a high school senior and current president of the student government at Great Neck North.</figcaption></figure><p class="p5">Oliver Pour, a senior at Great Neck <span class="s3">North High School and president of the </span>student body, gave a rousing address <span class="s3">to the crowd about the emotional toll of </span>gun violence at school.</p><p class="p5"><span class="s2">“I am proud to represent a student body that is over 1,100 strong,” said Pour. “Each one of us comes from a different walk of life, with a different story. But </span><span class="s3">every day, at 8 a.m., we converge onto </span><span class="s2">one place, where we are one family, one </span>voice. At 10 a.m. on March 14, we, the <span class="s3">students of Great Neck North, walked out, in silence and with conviction and solidarity. On that day, we commanded </span>the country’s airwaves, Twitter feeds <span class="s1">and Snapchat stories. We were the </span><span class="s3">news, because we collectively decided </span><span class="s2">that Enough Is Enough. We collectively decided that we do not feel safe in our schools. We collectively decided that gun laws have to change. How many more kids have to die before we could stop saying ‘Never Again! Enough Is Enough!’ My North family does not feel safe in our schools. We cannot go on, in sheer anxiety, scared that we are next. Our parents can not kiss us goodbye every morning, in a state of silent panic, wondering if this is the last time they’ll see us. School is where we need to feel safe. We do not. We, the students, stand strong across the country. We have a voice. And we want to be heard. And our message is ‘Enough Is Enough.’” </span></p><p class="p6"><span class="s4"><b>Interfaith Leaders Call for Action</b></span></p><figure id="attachment_38069" style="max-width: 300px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support.png"><img class="size-medium wp-image-38069" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support-300x227.png" alt="" width="300" height="227" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support-300x227.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support-556x420.png 556w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchI-Rabbi-Howard-Stecker-his-wife-Deanna-and-other-members-of-Temple-Israel-of-Great-Neck-showed-their-support.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Rabbi Howard Stecker, his wife, Deanna, and members of Temple Israel of Great Neck showed their support.</figcaption></figure><p class="p5"><span class="s3">Several members of the clergy were </span><span class="s2">featured speakers at the event, including </span>Rabbi Gordon Yaffe and Reverend Canon Joseph S. Pae.</p><p class="p5">“A rally on Shabbat?,” Rabbi Tara Feldman of Temple Beth-El, who just returned from a trip to Israel, asked <span class="s1">herself. “Just back from Jerusalem, </span>I am making an extra effort to uphold <span class="s2">the sanctity of the Sabbath. Should I, as a rabbi, be coming out [to the rally]? Absolutely! For as a Jew, I know that the obligation to save a life (<i>piku’ach nefesh</i>) supersedes the observance of Shabbat. And that is why we are here. We are here to save lives. On this <i>Shabbat HaGadol</i>, </span>the Sabbath which precedes Passover, <span class="s2">we remember that the key ingredients for liberation, for change, for transformation is the ability to open one’s heart, the capacity for courageous outrage and moral clarity.” </span></p><figure id="attachment_38079" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck.png"><img class="size-medium wp-image-38079" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-300x225.png" alt="" width="300" height="225" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-300x225.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-561x420.png 561w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">A group of supporters from Temple Beth-El of Great Neck expressed their message.</figcaption></figure><p class="p5"><span class="s2">Father Pae stressed our common human dignity in the quest for a more peaceful world. </span></p><p class="p5"><span class="s2">“I want to talk about something that is often forgotten in our society: dignity, dignity of human beings,” said Pae. “Do we, as a society, strive to respect the dignity of every human being? I mean everybody—not only the popular, the successful, the wealthy and the powerful. Regardless of the color of your skin, </span><span class="s3">regardless of your accent, regardless </span><span class="s2">of your status. Everybody. Dignity is not something you earn. Dignity is not something you buy. Dignity cannot be taken away. Dignity is given as a gift. We are born with it as we are created in the image of God. Unfortunately, our society </span>has many voices that say otherwise, <span class="s4">making us feeling less than others, feeling </span>excluded, feeling inadequate. Your <span class="s2">dignity is not dependent on your report cards, what college you went to, how </span><span class="s3">much you make, what kind of job you </span><span class="s2">have, what kind of cars you drive, how big your home is, where you live or what kind of family you come from. In order to make that kind of society, you need to know a few things: You are important. </span>You are precious. You are enough. Let <span class="s2">me repeat that. You are important, you are precious, you are enough.” </span></p><figure id="attachment_38068" style="max-width: 300px" class="wp-caption alignright"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann.png"><img class="size-medium wp-image-38068" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann-300x224.png" alt="" width="300" height="224" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann-300x224.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann-562x420.png 562w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchH-Local-activist-and-author-Lois-Schaffer-Veronica-Lurvey-Rabbi-Tara-Feldman-and-Beth-Friedmann.png 586w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">From left: local activist and author Lois Schaffer, Veronica Lurvey, Rabbi Tara Feldman and Beth Friedmann</figcaption></figure><p class="p5"><span class="s1">Great Neck resident Lois Schaffer, </span><span class="s3">author of <i>The Unthinkable: Life, Loss </i></span><i>and a Mother’s Mission to Ban Illegal </i><span class="s3"><i>Guns</i>, was especially moving. Since tragically losing her daughter Susie to </span>gun violence, she has devoted her life to protecting human rights.</p><p class="p5">“Gun violence is a cancer on our <span class="s2">society that is growing unchecked,” she said in her heart-wrenching memoir. </span><span class="s1">“A single bullet can extinguish the life </span><span class="s2">of an innocent person. This is America, </span>supposedly a humane society, and yet we witness tragic deaths daily due to gun violence.”</p><figure id="attachment_38070" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchJ.png"><img class="size-medium wp-image-38070" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchJ-300x202.png" alt="" width="300" height="202" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchJ-300x202.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchJ.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Teachers participated in the Great Neck rally with Don Ashkenase, Great Neck Board of Education trustee, and North Hempstead Supervisor Judi Bosworth, a former second-grade teacher in New York City and a trustee of the Great Neck Board of Education for 16 years.</figcaption></figure><p class="p5"><span class="s2">New York State Comptroller Thomas </span>DiNapoli energized the crowd with his <span class="s2">speech. While introducing him, North Shore Action president Veronica Lurvey discussed DiNapoli’s youth, when he won his first election in 1972, becoming the first 18 year old in New York State to hold public office. </span></p><p class="p6"><b>Rally Speakers and Sponsors</b></p><p class="p5"><span class="s3">In addition to the student advocates who led the rally, North Shore Action invited speakers from both sides </span><span class="s1">of the political aisle and interfaith </span><span class="s3">communities. In order of appearance, speakers were Beth Friedmann and Veronica Lurvey, presidents of North Shore Action and emcees; Jacob Lurvey, a junior at Schechter School of Long Island and president of the Great Neck USY Chapter, who led the Pledge of Allegiance; Alexa Tubian, a Great Neck North senior, who led the National Anthem and performed “Rise Up”; middle school students Sabrina Namigohar, Joane Sarfati and Hannah Sutin, who recited the names of the slain Parkland, FL, victims; Rebecca Sassouni, Great Neck Board of Education trustee; Oliver Pour, Great Neck North High student body president; Town of North Hempstead Councilwoman Anna Kaplan, Supervisor Judi Bosworth and Councilwoman Dina De Giorgio; </span><span class="s1">Thomas DiNapoli, New York State </span><span class="s2">Comptroller; Grace Meng, United States </span><span class="s1">Congress; Rabbi Tara Feldman of Temple Beth-El of Great Neck; Rabbi Gordon Yaffe, founder of Interfaith Community Action Committee of </span><span class="s3">Eastern Queens and Western Nassau County; Rev. Canon Joseph S. Pae, All </span><span class="s1">Saints Episcopal Church and Great </span><span class="s3">Neck Episcopal Ministry; Sandy Lubert, </span><span class="s1">a retired Great Neck Public Schools </span><span class="s2">teacher; Matt Wigler, a Great Neck North </span><span class="s3">graduate; Talia Katz, a Great Neck South </span><span class="s1">High sophomore; and Lois Schaffer, a gun-control activist and author. </span></p><figure id="attachment_38082" style="max-width: 300px" class="wp-caption alignleft"><a href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler.png"><img class="size-medium wp-image-38082" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler-300x192.png" alt="" width="300" height="192" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler-300x192.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler.png 585w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Town of North Hempstead Councilwoman Anna Kaplan (left), who spoke at the event, is pictured with Andrew Wigler (right).</figcaption></figure><p class="p5"><span class="s1">Event sponsors included All Saints Episcopal Church and Great Neck Episcopal Ministry, Great Neck Democratic Club, Great Neck Republican Committee &amp; Club, </span><span class="s2">Interfaith Community Action Committee </span><span class="s1">of Eastern Queens and Western Nassau County, Lake Success Jewish Center, North Hempstead Democratic Committee, North Shore Action, </span><span class="s3">Reach Out America and Samuel Field Y.</span></p><p class="p5"><span class="s2">In her concluding remarks, Lurvey </span><span class="s3">promised the students: “The eloquence </span><span class="s1">and strength we have seen on this </span><span class="s2">stage displayed by our students has been tremendous. And, on behalf of all of us </span><span class="s4">here, I pledge to you: We adults will listen, </span><span class="s2">because you are the leaders here and </span><span class="s3">you will be a force to be reckoned with. </span><span class="s2">You will register to vote, you will not stop marching and rallying, speaking and </span>demanding that something be done.”</p><style type="text/css">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</style><div id="td_uid_2_5ac6c16334e2c" class="td-gallery td-slide-on-2-columns"><div class="post_td_gallery"><div class="td-gallery-slide-top"><div class="td-gallery-title"></div><div class="td-gallery-controls-wrapper"><div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 20</div><div class="td-gallery-slide-prev-next-but"> <i class = "td-icon-left doubleSliderPrevButton"></i> <i class = "td-icon-right doubleSliderNextButton"></i></div></div></div><div class = "td-doubleSlider-1 "><div class = "td-slider"><div class = "td-slide-item td-item1"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchG-Matt-Wigler-former-student-body-President-of-Great-Neck-North-spoke-about-the-history-of-civil-protests-in-Great-Neck.png" title="EnoughMarchG Matt Wigler, former student body President of Great Neck North, spoke about the history of civil protests in Great Neck"  data-caption="Matt Wigler, former student body president of Great Neck North, spoke about the history of civil protests in Great Neck."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchG-Matt-Wigler-former-student-body-President-of-Great-Neck-North-spoke-about-the-history-of-civil-protests-in-Great-Neck.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchG-Matt-Wigler-former-student-body-President-of-Great-Neck-North-spoke-about-the-history-of-civil-protests-in-Great-Neck.png 585w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchG-Matt-Wigler-former-student-body-President-of-Great-Neck-North-spoke-about-the-history-of-civil-protests-in-Great-Neck-300x201.png 300w" sizes="(max-width: 585px) 100vw, 585px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Matt Wigler, former student body president of Great Neck North, spoke about the history of civil protests in Great Neck.</div></figcaption></figure></div><div class = "td-slide-item td-item2"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience.png" title="EnoughMarchO Student Alexa Tubian sang “Rise Up” to a very appreciative audience"  data-caption="Student Alexa Tubian sang “Rise Up” to a very appreciative audience."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience-562x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience-562x420.png 562w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience-300x224.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchO-Student-Alexa-Tubian-sang-“Rise-Up”-to-a-very-appreciative-audience.png 587w" sizes="(max-width: 562px) 100vw, 562px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Student Alexa Tubian sang “Rise Up” to a very appreciative audience.</div></figcaption></figure></div><div class = "td-slide-item td-item3"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchK-Signs-in-English-and-Hebrew-stressing-the-need-to-act-to-change-gun-laws.png" title="EnoughMarchK Signs in English and Hebrew stressing the need to act to change gun laws"  data-caption="Signs in English and Hebrew stressed the need to change gun laws."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchK-Signs-in-English-and-Hebrew-stressing-the-need-to-act-to-change-gun-laws.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchK-Signs-in-English-and-Hebrew-stressing-the-need-to-act-to-change-gun-laws.png 589w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchK-Signs-in-English-and-Hebrew-stressing-the-need-to-act-to-change-gun-laws-300x199.png 300w" sizes="(max-width: 589px) 100vw, 589px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Signs in English and Hebrew stressed the need to change gun laws.</div></figcaption></figure></div><div class = "td-slide-item td-item4"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio.png" title="EnoughMarchM Nassau County Legislator Ellen Birnbaum, Great Neck Plaza Mayor Jean Celender, Councilwoman Dina De Giorgio"  data-caption="From left: Nassau County Legislator Ellen Birnbaum, Great Neck Plaza Mayor Jean Celender and Councilwoman Dina De Giorgio"  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio-560x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio-560x420.png 560w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio-300x225.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchM-Nassau-County-Legislator-Ellen-Birnbaum-Great-Neck-Plaza-Mayor-Jean-Celender-Councilwoman-Dina-De-Giorgio.png 587w" sizes="(max-width: 560px) 100vw, 560px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">From left: Nassau County Legislator Ellen Birnbaum, Great Neck Plaza Mayor Jean Celender and Councilwoman Dina De Giorgio</div></figcaption></figure></div><div class = "td-slide-item td-item5"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchN-Maurice-Harounian-and-Joey-Harounian-Great-Neck-North-Middle-School.png" title="EnoughMarchN Maurice Harounian and Joey Harounian, Great Neck North Middle School"  data-caption="Maurice Harounian and Joey Harounian, a student at Great Neck North Middle School"  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchN-Maurice-Harounian-and-Joey-Harounian-Great-Neck-North-Middle-School.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchN-Maurice-Harounian-and-Joey-Harounian-Great-Neck-North-Middle-School.png 586w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchN-Maurice-Harounian-and-Joey-Harounian-Great-Neck-North-Middle-School-300x200.png 300w" sizes="(max-width: 586px) 100vw, 586px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Maurice Harounian and Joey Harounian, a student at Great Neck North Middle School</div></figcaption></figure></div><div class = "td-slide-item td-item6"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchP.png" title="EnoughMarchP"  data-caption="Families demanded action."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchP.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchP.png 588w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchP-300x200.png 300w" sizes="(max-width: 588px) 100vw, 588px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Families demanded action.</div></figcaption></figure></div><div class = "td-slide-item td-item7"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ.png" title="EnoughMarchQ"  data-caption="The crowd was passionate."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ-559x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ-559x420.png 559w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ-300x225.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchQ.png 586w" sizes="(max-width: 559px) 100vw, 559px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">The crowd was passionate.</div></figcaption></figure></div><div class = "td-slide-item td-item8"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchR.png" title="EnoughMarchR"  data-caption="Many families attended the rally."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchR-315x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchR-315x420.png 315w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchR-225x300.png 225w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchR.png 439w" sizes="(max-width: 315px) 100vw, 315px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Many families attended the rally.</div></figcaption></figure></div><div class = "td-slide-item td-item9"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck.png" title="EnoughMarchS A group of supporters from Temple Beth-El of Great Neck"  data-caption="A group of supporters from Temple Beth-El of Great Neck expressed their message."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-561x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-561x420.png 561w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-300x225.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck-265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchS-A-group-of-supporters-from-Temple-Beth-El-of-Great-Neck.png 585w" sizes="(max-width: 561px) 100vw, 561px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">A group of supporters from Temple Beth-El of Great Neck expressed their message.</div></figcaption></figure></div><div class = "td-slide-item td-item10"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchT.png" title="EnoughMarchT"  data-caption="People of all ages came to express their concerns."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchT.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchT.png 585w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchT-300x201.png 300w" sizes="(max-width: 585px) 100vw, 585px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">People of all ages came to express their concerns.</div></figcaption></figure></div><div class = "td-slide-item td-item11"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchU.png" title="EnoughMarchU"  data-caption="Even young kids shared their thoughts."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchU-317x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchU-317x420.png 317w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchU-226x300.png 226w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchU.png 441w" sizes="(max-width: 317px) 100vw, 317px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Even young kids shared their thoughts.</div></figcaption></figure></div><div class = "td-slide-item td-item12"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler.png" title="EnoughMarchV Anna Kaplan, Councilwoman, Town of North Hempstead spoke at the event, pictured with Andrew Wigler"  data-caption="Town of North Hempstead Councilwoman Anna Kaplan (left), who spoke at the event, is pictured with Andrew Wigler (right)."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler.png 585w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchV-Anna-Kaplan-Councilwoman-Town-of-North-Hempstead-spoke-at-the-event-pictured-with-Andrew-Wigler-300x192.png 300w" sizes="(max-width: 585px) 100vw, 585px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Town of North Hempstead Councilwoman Anna Kaplan (left), who spoke at the event, is pictured with Andrew Wigler (right).</div></figcaption></figure></div><div class = "td-slide-item td-item13"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchW-Great-Neck-North-Students-including-Andrew-Lin.png" title="EnoughMarchW Great Neck North Students including Andrew Lin"  data-caption="Andrew Lin (second from left) was one of the Great Neck North students demanding action."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchW-Great-Neck-North-Students-including-Andrew-Lin-315x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchW-Great-Neck-North-Students-including-Andrew-Lin-315x420.png 315w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchW-Great-Neck-North-Students-including-Andrew-Lin-225x300.png 225w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchW-Great-Neck-North-Students-including-Andrew-Lin.png 440w" sizes="(max-width: 315px) 100vw, 315px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Andrew Lin (second from left) was one of the Great Neck North students demanding action.</div></figcaption></figure></div><div class = "td-slide-item td-item14"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchX.png" title="EnoughMarchX"  data-caption="Moms came to make their voices heard."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchX.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchX.png 584w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchX-300x200.png 300w" sizes="(max-width: 584px) 100vw, 584px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Moms came to make their voices heard.</div></figcaption></figure></div><div class = "td-slide-item td-item15"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchY-The-Kane-Family.png" title="EnoughMarchY The Kane Family"  data-caption="The Kane family"  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchY-The-Kane-Family-316x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchY-The-Kane-Family-316x420.png 316w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchY-The-Kane-Family-226x300.png 226w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchY-The-Kane-Family.png 587w" sizes="(max-width: 316px) 100vw, 316px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">The Kane family</div></figcaption></figure></div><div class = "td-slide-item td-item16"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZ.png" title="EnoughMarchZ"  data-caption="Communities members of all ages made their voices heard."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZ-316x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZ-316x420.png 316w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZ-226x300.png 226w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZ.png 586w" sizes="(max-width: 316px) 100vw, 316px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Communities members of all ages made their voices heard.</div></figcaption></figure></div><div class = "td-slide-item td-item17"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZA.png" title="EnoughMarchZA"  data-caption="Communities members of all ages made their voices heard."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZA.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZA.png 586w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZA-300x200.png 300w" sizes="(max-width: 586px) 100vw, 586px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Communities members of all ages made their voices heard.</div></figcaption></figure></div><div class = "td-slide-item td-item18"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents.jpg" title="EnoughMarchZC Great Neck elementary and middle school students, Olivia Yachbes, Melanie Weinreich, Eden Rosenberg and Sophia Rosenberg attend the rally with with parents"  data-caption="Great Neck elementary and middle school students Olivia Yachbes, Melanie Weinreich, Eden Rosenberg and Sophia Rosenberg attended the rally with their parents."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-315x420.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-315x420.jpg 315w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-225x300.jpg 225w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-768x1024.jpg 768w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-696x928.jpg 696w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZC-Great-Neck-elementary-and-middle-school-students-Olivia-Yachbes-Melanie-Weinreich-Eden-Rosenberg-and-Sophia-Rosenberg-attend-the-rally-with-with-parents-1068x1424.jpg 1068w" sizes="(max-width: 315px) 100vw, 315px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Great Neck elementary and middle school students Olivia Yachbes, Melanie Weinreich, Eden Rosenberg and Sophia Rosenberg attended the rally with their parents.</div></figcaption></figure></div><div class = "td-slide-item td-item19"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png" title="EnoughMarchD"  data-caption="Great Neck student leaders who spoke at the rally, Talia Katz, Sabrina Namigohar, Matt Wigler, Joanne Sarfati, Hannah Sutin and Oliver Pour, are with Veronica Lurvey and Beth Friedmann, presidents of North Shore Action."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--562x420.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--562x420.png 562w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--300x224.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--80x60.png 80w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--265x198.png 265w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png 586w" sizes="(max-width: 562px) 100vw, 562px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Great Neck student leaders who spoke at the rally, Talia Katz, Sabrina Namigohar, Matt Wigler, Joanne Sarfati, Hannah Sutin and Oliver Pour, are with Veronica Lurvey and Beth Friedmann, presidents of North Shore Action.</div></figcaption></figure></div><div class = "td-slide-item td-item20"><figure class="td-slide-galery-figure td-slide-popup-gallery"> <a class="slide-gallery-image-link" href="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZB.png" title="EnoughMarchZB"  data-caption="Some of the rally speakers gathered with local elected officials and event organizers, including Ellen Birnbaum, Anna Kaplan, Wayne Wink, Judi Bosworth, Anthony D’Urso and Rebecca Sassouni, Great Neck Board of Education trustee."  data-description=""> <img src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZB.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZB.png 586w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZB-300x184.png 300w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchZB-356x220.png 356w" sizes="(max-width: 586px) 100vw, 586px" alt=""> </a><figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Some of the rally speakers gathered with local elected officials and event organizers, including Ellen Birnbaum, Anna Kaplan, Wayne Wink, Judi Bosworth, Anthony D’Urso and Rebecca Sassouni, Great Neck Board of Education trustee.</div></figcaption></figure></div></div></div><div class = "td-doubleSlider-2"><div class = "td-slider"><div class = "td-button td-item1"><div class = "td-border"></div></div><div class = "td-button td-item2"><div class = "td-border"></div></div><div class = "td-button td-item3"><div class = "td-border"></div></div><div class = "td-button td-item4"><div class = "td-border"></div></div><div class = "td-button td-item5"><div class = "td-border"></div></div><div class = "td-button td-item6"><div class = "td-border"></div></div><div class = "td-button td-item7"><div class = "td-border"></div></div><div class = "td-button td-item8"><div class = "td-border"></div></div><div class = "td-button td-item9"><div class = "td-border"></div></div><div class = "td-button td-item10"><div class = "td-border"></div></div><div class = "td-button td-item11"><div class = "td-border"></div></div><div class = "td-button td-item12"><div class = "td-border"></div></div><div class = "td-button td-item13"><div class = "td-border"></div></div><div class = "td-button td-item14"><div class = "td-border"></div></div><div class = "td-button td-item15"><div class = "td-border"></div></div><div class = "td-button td-item16"><div class = "td-border"></div></div><div class = "td-button td-item17"><div class = "td-border"></div></div><div class = "td-button td-item18"><div class = "td-border"></div></div><div class = "td-button td-item19"><div class = "td-border"></div></div><div class = "td-button td-item20"><div class = "td-border"></div></div></div></div></div></div><p class="p5"><span class="s2">She continued, “This is when we need </span>our elected officials of every party to <span class="s1">listen and act. Not just when it’s easy, </span><span class="s3">but when it’s hard. There are going to be some big elections in November and </span><span class="s1">we will be electing leaders on this issue—not followers, leaders. We will remember who voted to keep our </span><span class="s3">schools safe and who was afraid of the </span><span class="s2">gun lobby. Looking these students in the eyes, we pledge today that we will not be afraid. For their sake, go in peace and with the hope that next year at this time, there will be no need for another rally.” </span></p><p class="p5"><span class="s1">North Shore Action’s motto is: </span><span class="s2">“We are one community.” To find out more about upcoming events, contact <a href="mailto:northshoreaction@gmail.com" target="_blank" rel="noopener">northshoreaction@gmail.com</a> or visit the group’s <a href="https://www.facebook.com/NorthShoreAction/" target="_blank" rel="noopener">Facebook page</a>.</span></p><p class="p7"><span class="s1"><i>Great Neck resident Jacqueline </i></span><span class="s2"><i>Harounian is a frequent contributor to the </i>Great Neck Record<i> and a member of the steering committee of North Shore </i></span><span class="s1"><i>Action, which organized the March for Our Lives Rally in Great Neck. </i></span></p></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Local+Students+Lead+Charge+On+Gun+Control&url=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F&via=Great+Neck+Record"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://greatneckrecord.com/local-students-lead-charge-on-gun-control/&amp;media=http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png&description=Local+Students+Lead+Charge+On+Gun+Control" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Local+Students+Lead+Charge+On+Gun+Control%20-%20http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" ><i class="td-icon-whatsapp"></i></a></div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://greatneckrecord.com/local-students-lead-charge-on-gun-control/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" data-text="Local Students Lead Charge On Gun Control" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/">Erin Lipinsky Sets New Fundraising Record</a></div></div><div class="td-next-prev-separator"></div></div><div class="author-box-wrap"><a href="http://greatneckrecord.com/author/jacqueline-harounian/"><img width="96" height="96" src="http://greatneckrecord.com/wp-content/uploads/2017/11/SuicideJacqueline-HarounianColA-150x150.jpg" class="avatar avatar-96 photo" alt="" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://greatneckrecord.com/author/jacqueline-harounian/">Jacqueline Harounian</a></span></div><div class="td-author-description">Jacqueline Harounian is a lawyer serving Great Neck in family law and real estate and a columnist for <em>Great Neck Record</em>.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Jacqueline Harounian"></span><meta itemprop="datePublished" content="2018-04-05T06:05:49+00:00"><meta itemprop="dateModified" content="2018-04-03T16:06:43+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogo.jpg"></span><meta itemprop="name" content="Great Neck Record"></span><meta itemprop="headline " content="Local Students Lead Charge On Gun Control"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD-.png"><meta itemprop="width" content="586"><meta itemprop="height" content="438"></span></footer></article><div class="td_block_wrap td_block_related_posts td_uid_5_5ac6c16350016_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_5_5ac6c16350016" ><script>var block_td_uid_5_5ac6c16350016 = new tdBlock();
block_td_uid_5_5ac6c16350016.id = "td_uid_5_5ac6c16350016";
block_td_uid_5_5ac6c16350016.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_5_5ac6c16350016_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_5_5ac6c16350016_rand","live_filter":"cur_post_same_categories","live_filter_cur_post_id":38149,"live_filter_cur_post_author":"112","block_template_id":""}';
block_td_uid_5_5ac6c16350016.td_column_number = "3";
block_td_uid_5_5ac6c16350016.block_type = "td_block_related_posts";
block_td_uid_5_5ac6c16350016.post_count = "3";
block_td_uid_5_5ac6c16350016.found_posts = "3155";
block_td_uid_5_5ac6c16350016.header_color = "";
block_td_uid_5_5ac6c16350016.ajax_pagination_infinite_stop = "";
block_td_uid_5_5ac6c16350016.max_num_pages = "1052";
tdBlocksArray.push(block_td_uid_5_5ac6c16350016);</script><h4 class="td-related-title td-block-title"><a id="td_uid_6_5ac6c163591bb" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_5_5ac6c16350016" href="#">RELATED ARTICLES</a><a id="td_uid_7_5ac6c16359207" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_5_5ac6c16350016" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_5_5ac6c16350016 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/" rel="bookmark" title="Erin Lipinsky Sets New Fundraising Record"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-218x150.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-218x150.jpg 218w, http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Erin Lipinsky Sets New Fundraising Record"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/" rel="bookmark" title="Erin Lipinsky Sets New Fundraising Record">Erin Lipinsky Sets New Fundraising Record</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/silverstein-girls-basketball-team-wins-championship/" rel="bookmark" title="Silverstein Girls Basketball Team Wins Championship"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-218x150.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-218x150.jpg 218w, http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Silverstein Girls Basketball Team Wins Championship"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/silverstein-girls-basketball-team-wins-championship/" rel="bookmark" title="Silverstein Girls Basketball Team Wins Championship">Silverstein Girls Basketball Team Wins Championship</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="http://greatneckrecord.com/board-commends-north-high-students-3/" rel="bookmark" title="Board Commends North High Students"><img width="218" height="150" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-218x150.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-218x150.jpg 218w, http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Board Commends North High Students"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/board-commends-north-high-students-3/" rel="bookmark" title="Board Commends North High Students">Board Commends North High Students</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5ac6c16350016" data-td_block_id="td_uid_5_5ac6c16350016"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_5_5ac6c16350016" data-td_block_id="td_uid_5_5ac6c16350016"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/local-students-lead-charge-on-gun-control/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&#038;postid=38149&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.9&#038;sig=c64566b6e82fc63ac290faf5c955610228ef0c7e#parent=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe> <!--[if !IE]><!--> <script>document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});</script> <!--<![endif]--></form></div> <input type="hidden" name="comment_parent" id="comment_parent" value="" /></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td_block_wrap td_block_7 td_block_widget td_uid_8_5ac6c1635ec64_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_8_5ac6c1635ec64" ><style>body .td_uid_8_5ac6c1635ec64_rand .td_module_wrap:hover .entry-title a,
            body .td_uid_8_5ac6c1635ec64_rand .td-pulldown-filter-link:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-subcat-item a:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-subcat-item .td-cur-simple-item,
            body .td_uid_8_5ac6c1635ec64_rand .td_quote_on_blocks,
            body .td_uid_8_5ac6c1635ec64_rand .td-opacity-cat .td-post-category:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-opacity-read .td-read-more a:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-opacity-author .td-post-author-name a:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-instagram-user a {
                color: #000000;
            }

            body .td_uid_8_5ac6c1635ec64_rand .td-next-prev-wrap a:hover,
            body .td_uid_8_5ac6c1635ec64_rand .td-load-more-wrap a:hover {
                background-color: #000000;
                border-color: #000000;
            }

            body .td_uid_8_5ac6c1635ec64_rand .block-title > *,
            body .td_uid_8_5ac6c1635ec64_rand .td-trending-now-title,
            body .td_uid_8_5ac6c1635ec64_rand .td-read-more a,
            body .td_uid_8_5ac6c1635ec64_rand .td-weather-information:before,
            body .td_uid_8_5ac6c1635ec64_rand .td-weather-week:before,
            body .td_uid_8_5ac6c1635ec64_rand .td-subcat-dropdown:hover .td-subcat-more,
            body .td_uid_8_5ac6c1635ec64_rand .td-exchange-header:before,
            body .td-footer-wrapper .td_uid_8_5ac6c1635ec64_rand .td-post-category,
            body .td_uid_8_5ac6c1635ec64_rand .td-post-category:hover {
                background-color: #000000;
            }
            body .td-footer-wrapper .td_uid_8_5ac6c1635ec64_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            body .td_uid_8_5ac6c1635ec64_rand .block-title {
                border-color: #000000;
            }</style><script>var block_td_uid_8_5ac6c1635ec64 = new tdBlock();
block_td_uid_8_5ac6c1635ec64.id = "td_uid_8_5ac6c1635ec64";
block_td_uid_8_5ac6c1635ec64.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"221","category_ids":"","custom_title":"Featured","custom_url":"greatneckrecord.com\/category\/featured","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#000000","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_8_5ac6c1635ec64_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_5ac6c1635ec64_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_8_5ac6c1635ec64.td_column_number = "1";
block_td_uid_8_5ac6c1635ec64.block_type = "td_block_7";
block_td_uid_8_5ac6c1635ec64.post_count = "5";
block_td_uid_8_5ac6c1635ec64.found_posts = "1918";
block_td_uid_8_5ac6c1635ec64.header_color = "#000000";
block_td_uid_8_5ac6c1635ec64.ajax_pagination_infinite_stop = "";
block_td_uid_8_5ac6c1635ec64.max_num_pages = "384";
tdBlocksArray.push(block_td_uid_8_5ac6c1635ec64);</script><div class="td-block-title-wrap"><h4 class="block-title"><a href="http://greatneckrecord.com/category/featured" class="td-pulldown-size">Featured</a></h4></div><div id=td_uid_8_5ac6c1635ec64 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" rel="bookmark" title="Local Students Lead Charge On Gun Control"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--100x70.png" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--100x70.png 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/EnoughMarchD--218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Local Students Lead Charge On Gun Control"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/local-students-lead-charge-on-gun-control/" rel="bookmark" title="Local Students Lead Charge On Gun Control">Local Students Lead Charge On Gun Control</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-05T06:05:49+00:00" >April 5, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/" rel="bookmark" title="Erin Lipinsky Sets New Fundraising Record"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/ErinPolarPlungeA-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Erin Lipinsky Sets New Fundraising Record"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/erin-lipinsky-sets-new-fundraising-record/" rel="bookmark" title="Erin Lipinsky Sets New Fundraising Record">Erin Lipinsky Sets New Fundraising Record</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-04T06:05:27+00:00" >April 4, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/silverstein-girls-basketball-team-wins-championship/" rel="bookmark" title="Silverstein Girls Basketball Team Wins Championship"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/SportsSHAB-4112-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Silverstein Girls Basketball Team Wins Championship"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/silverstein-girls-basketball-team-wins-championship/" rel="bookmark" title="Silverstein Girls Basketball Team Wins Championship">Silverstein Girls Basketball Team Wins Championship</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-03T06:05:36+00:00" >April 3, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/board-commends-north-high-students-3/" rel="bookmark" title="Board Commends North High Students"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/GNPS-NH-Bd-Recog-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Board Commends North High Students"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/board-commends-north-high-students-3/" rel="bookmark" title="Board Commends North High Students">Board Commends North High Students</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-02T06:03:07+00:00" >April 2, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="http://greatneckrecord.com/community-church-holds-easter-egg-hunt/" rel="bookmark" title="Community Church Holds Easter Egg Hunt"><img width="100" height="70" class="entry-thumb" src="http://greatneckrecord.com/wp-content/uploads/2018/03/EasterEggHuntG-100x70.jpg" srcset="http://greatneckrecord.com/wp-content/uploads/2018/03/EasterEggHuntG-100x70.jpg 100w, http://greatneckrecord.com/wp-content/uploads/2018/03/EasterEggHuntG-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Community Church Holds Easter Egg Hunt"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="http://greatneckrecord.com/community-church-holds-easter-egg-hunt/" rel="bookmark" title="Community Church Holds Easter Egg Hunt">Community Church Holds Easter Egg Hunt</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-04-01T06:03:11+00:00" >April 1, 2018</time></span></div></div></div></div></div></div><div class="td-a-rec td-a-rec-id-custom_ad_1  "><div id='div-gpt-ad-1463590303247-4' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-4'); });</script> </div></div><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Great Neck Area News</span></h4><div class="textwidget"><div id="w6897_widget"></div><script language="JavaScript" src="http://tools.prnewswire.com/en-us/live/6897/widget.js"></script> </div></aside><div class="td-a-rec td-a-rec-id-custom_ad_3  "><div id='div-gpt-ad-1463590303247-5' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-5'); });</script> </div></div><aside class="td_block_template_1 widget widget_rss"><h4 class="block-title"><span><a class="rsswidget" href="https://longislandweekly.com/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://greatneckrecord.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://longislandweekly.com/">Long Island Weekly</a></span></h4><ul><li><a class='rsswidget' href='https://longislandweekly.com/juniors-restaurant-celebrates-national-grilled-cheese-day/'>Junior’s Restaurant Celebrates National Grilled Cheese Day</a></li><li><a class='rsswidget' href='https://longislandweekly.com/day-trips-to-take-in-new-york/'>Day Trips To Take In New York</a></li><li><a class='rsswidget' href='https://longislandweekly.com/long-island-gardens-to-visit-in-the-spring/'>Long Island Gardens To Visit In The Spring</a></li><li><a class='rsswidget' href='https://longislandweekly.com/bottoms-up/'>Bottoms Up</a></li><li><a class='rsswidget' href='https://longislandweekly.com/progressive-op-restores-hope-and-renews-life-for-limb-loss-patients/'>Progressive O&amp;P Restores Hope And Renews Life For Limb Loss Patients</a></li></ul></aside></div></div></div></div></div><div class="td-footer-wrapper td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-a-rec td-a-rec-id-footer_top  "><div id='div-gpt-ad-1463590303247-2' style='height:90px; width:728px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463590303247-2'); });</script> </div></div></div></div><div class="td-pb-row"><div class="td-pb-span12"></div></div></div><div class="td-footer-bottom-full"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://greatneckrecord.com/"><img src="http://greatneckrecord.com/wp-content/uploads/2016/05/GreatNeck_WebLogoGray.jpg" alt="Great Neck Record" title="Great Neck Record"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Since 1908, <em>Great Neck Record</em> has served the communities of Great Neck, Great Neck Estates, Great Neck Plaza, Kensington, Kings Point, Lake Success, Russell Gardens, Saddle Rock, Thomaston and the unincorporated areas as a source for local news and community events.<div class="footer-email-wrap">Contact us: <a href="mailto:greatneck@antonmediagroup.com">greatneck@antonmediagroup.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GreatNeckRecord/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://plus.google.com/b/117482670940543624944" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/greatneckrecord" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></aside></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright 2017 • Anton Media Group • All Rights Reserved</div></div></div></div></div> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <div style="display:none"><div class="grofile-hash-map-f1bc377809e3ac2c79fe2d78376c0f8e"></div></div> <style type="text/css" media="screen">/* custom css theme panel */
.vc_single_image a {
    width: 100%;
    display: block;
    background-size: contain !important;
    background-repeat: no-repeat;
}</style> <script type='text/javascript'>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};</script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201814'></script> <script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Apraa'></script> <script type='text/javascript'>var WPGroHo = {"my_hash":""};</script>  <script>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</script> <!--[if IE]> <script type="text/javascript">if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}</script> <![endif]--> <script type="text/javascript">(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&postid=38149&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=c64566b6e82fc63ac290faf5c955610228ef0c7e#parent=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=35178715&postid=38149&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=c64566b6e82fc63ac290faf5c955610228ef0c7e#parent=http%3A%2F%2Fgreatneckrecord.com%2Flocal-students-lead-charge-on-gun-control%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();</script> <script type='text/javascript' src='https://stats.wp.com/e-201814.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'35178715',post:'38149',tz:'-4',srv:'greatneckrecord.com'} ]);
	_stq.push([ 'clickTrackerInit', '35178715', '38149' ]);</script> <script type="text/javascript" defer src="http://greatneckrecord.com/wp-content/cache/autoptimize/js/autoptimize_fd66323808ecafbd97703004f6f1a3a7.js"></script></body></html>